Bug 807729 - RFE: update to a recent release
RFE: update to a recent release
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: mercurial (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Vojtech Vitek
qe-baseos-daemons
: FutureFeature, Rebase
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-28 11:09 EDT by Jonathan Underwood
Modified: 2015-03-04 18:57 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-10 09:33:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Underwood 2012-03-28 11:09:06 EDT
Description of problem:
Would it be possible to update mercurial to a more recent release than 1.4? Mercurial is a leaf package (nothing else seems to require it), so this shouldn't be a major issue. The main motivation for this request is that the Eclipse plug-in requires at least mercurial 1.5. 1.4 is more than 3 years old at this point.

Version-Release number of selected component (if applicable):
mercurial-1.4-3.el6.x86_64
Comment 2 Ondrej Vasik 2012-03-28 15:18:37 EDT
Thanks for the suggestion, but without customers pushing for it via support ticket, the rebase is unlikely to happen - as the RHEL update capacity is limited. It is a kind of unfortunate situation - as the EPEL policy afaik forbids to ship newer than RHEL package - so you can't use EPEL for this.

Therefore - if you have an active subscription - please contact product support with this request to raise its priority - bugzilla is just tracking tool for RHEL.
Comment 3 Jonathan Underwood 2012-05-02 17:40:34 EDT
Well, the issue is that holding back the rhel version prevents packaging things for EPEL (such as the eclipse plugin), which was my motivation for making the request - I'm an EPEL contributor - I don't have an RHEL active subscription, in fact.
Comment 4 Ondrej Vasik 2012-05-10 09:33:10 EDT
I see your point, but I don't see a mercurial rebase likely to happen in RHEL-6 at the moment - it still needs a slot for testing and introduces risk of regression in production environment.

If there is some dependency issue for other potential epel packages/update, probably you could discuss some kind of exception on epel-devel list or on epel sig meeting - to have e.g. mercurial15 package in epel-6. It might be accepted by them, as you said, mercurial is leaf (and more toolchain) package.

Note You need to log in before you can comment on or make changes to this bug.