Bug 807740 - Segfaults seen in dmesg - mostly in ld-linux.so.2
Segfaults seen in dmesg - mostly in ld-linux.so.2
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.2
i686 Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-28 11:17 EDT by David Kutálek
Modified: 2013-06-20 02:31 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-20 02:31:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Kutálek 2012-03-28 11:17:55 EDT
Description of problem:

On one of ours machines, there is big number of segfaults seen in dmesg, like:

ld-linux.so.2[7326]: segfault at 4 ip 0053ba35 sp bfcfd894 error 4 in ld-2.12.so[535000+1e000]
tar[11071]: segfault at 2e2e2e2e ip 0050ea38 sp bf817d8c error 4 in libc-2.12.so[3d9000+189000]
make[15896]: segfault at 0 ip 0805e862 sp bfdda5f0 error 4 in make[8048000+28000]

Big majority of these are about ld-linux.so.2, and all are stating 'error 4' except these two:

npviewer.bin[26200]: segfault at 218 ip 03182496 sp bffa1a78 error 6 in libflashplayer.so[2f04000+bc4000]
dropwatch[29080]: segfault at 13 ip 0017ec93 sp bfd785d8 error 6 in libc-2.12.so[110000+189000]

I had a problem with rebuilding of openjdk src rpm yesterday, it ended with segfaults on various places, and always there was a new dmesg segfault entry after running it.

Version-Release number of selected component (if applicable):

.qa.[root@i386-6c-m1 ~]# uname -a
Linux *** 2.6.32-220.4.2.el6.i686 #1 SMP Mon Feb 6 16:46:31 EST 2012 i686 i686 i386 GNU/Linux
.qa.[root@i386-6c-m1 ~]# rpm -q kernel
kernel-2.6.32-220.4.1.el6.i686
kernel-2.6.32-220.4.2.el6.i686
kernel-2.6.32-220.7.1.el6.i686

.qa.[root@i386-6c-m1 ~]# rpm -q glibc
glibc-2.12-1.47.el6_2.9.i686


How reproducible:

Almost always by running complex rpmbuild command for java-1.6.0-openjdk

Steps to Reproduce:
1. rebuilding some openjdk package using rpmbuild --rebuild --target=i686
2. this is seen only on one specific i686 machine
3. 
  
Actual results:

segfaults causing tasks to fail

Expected results:

no segfaults seen

Additional info:

Access to this machine available on request
Comment 11 RHEL Product and Program Management 2012-05-03 01:24:36 EDT
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 12 Linda Wang 2013-06-20 02:31:47 EDT
Haven't seen any updates from David. so assume the segfault issue
went away. Close for now, please feel free to reopen if the issue
shows up again. many thanks.

Note You need to log in before you can comment on or make changes to this bug.