Bug 807752 - Should display appropriate error message when "Global profile user" tries to delete HWPs
Summary: Should display appropriate error message when "Global profile user" tries to ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: CloudForms Cloud Engine
Classification: Retired
Component: aeolus-conductor
Version: 1.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
Assignee: Scott Seago
QA Contact: wes hayutin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-03-28 15:36 UTC by Rehana
Modified: 2012-12-04 15:01 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
When a global profile user tried to delete Cloud Resource Profiles, the error message displayed was inadequate. This bug fix updates hardware_profiles_controller.rb to display the correct error message: "Insufficient permissions to delete hardware profile"
Clone Of:
Environment:
Last Closed: 2012-12-04 15:01:46 UTC


Attachments (Terms of Use)
Insufficient permissions error (90.97 KB, image/png)
2012-09-20 19:58 UTC, Ronelle Landy
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2012:1516 0 normal SHIPPED_LIVE CloudForms Cloud Engine 1.1 update 2012-12-04 19:51:45 UTC

Description Rehana 2012-03-28 15:36:51 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Create a user with only "global profile user"
2.Login to conductor as "Global profile user"
3.Go to Content --> Hardware
4. Select any hwp and click delete

Actual results:
Displayed the error msg "rehana_hmp1 could not be deleted "

Expected results:

This should be changed to "“Insufficient privileges to do the operation or so” 

Additional info:

rpm -qa | grep aeolus
aeolus-conductor-0.8.3-1.el6.noarch
aeolus-conductor-daemons-0.8.3-1.el6.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-configure-2.5.2-1.el6.noarch
aeolus-all-0.8.3-1.el6.noarch
rubygem-aeolus-cli-0.3.1-1.el6.noarch
aeolus-conductor-doc-0.8.3-1.el6.noarch

Comment 1 Scott Seago 2012-09-04 15:39:03 UTC
patch on list:
[PATCH conductor] bug 807752: appropriate error message for  permission denied on HWP deletion

Comment 2 Scott Seago 2012-09-06 15:29:41 UTC
commit 95d037bffb0a0c394064a4d641afe3e0742fc796
Author: Scott Seago <sseago@redhat.com>
Date:   Wed Sep 5 14:26:18 2012 -0400

    bug 807752: appropriate error message for permission denied on HWP deletion
    
    https://bugzilla.redhat.com/show_bug.cgi?id=807752
    
    Signed-off-by: Jason Guiditta <jguiditt@redhat.com>

On 1.1 at b191d199cd9a886f7b68c9493991ba28d6b062dc

Comment 3 Steve Linabery 2012-09-07 21:50:01 UTC
in build aeolus-conductor-0.13.3-1.el6cf

Comment 5 Ronelle Landy 2012-09-20 19:57:20 UTC
Testing rpms:

>> rpm -qa |grep aeolus
aeolus-configure-2.8.6-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
aeolus-conductor-0.13.8-1.el6cf.noarch
aeolus-conductor-daemons-0.13.8-1.el6cf.noarch
aeolus-conductor-doc-0.13.8-1.el6cf.noarch
aeolus-all-0.13.8-1.el6cf.noarch

 - Created a user with only Global HWP User Permissions
 - Logged in to Conductor as that user
 - Navigated to Administer-> Content -> Hardware
 - Tried to delete the mock HWP set up
 - Received the following error:  

Errors
Insufficient permissions to delete hardware profile mockX86_64LARGE 

See the attached screenshot

Marking this BZ as 'verified'.

Comment 6 Ronelle Landy 2012-09-20 19:58:19 UTC
Created attachment 615106 [details]
Insufficient permissions error

Comment 8 errata-xmlrpc 2012-12-04 15:01:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html


Note You need to log in before you can comment on or make changes to this bug.