Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 807757 - systemd doesn't take care of ipmievd service fail
Summary: systemd doesn't take care of ipmievd service fail
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ipmitool
Version: 17
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Jan Safranek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 816135
TreeView+ depends on / blocked
 
Reported: 2012-03-28 15:49 UTC by Martin Cermak
Modified: 2012-06-05 12:01 UTC (History)
1 user (show)

Fixed In Version: ipmitool-1.8.11-10.fc17 ipmitool-1.8.11-10.fc18
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-26 06:52:11 UTC
Type: ---


Attachments (Terms of Use)

Description Martin Cermak 2012-03-28 15:49:24 UTC
Description of problem:

  systemd doesn't take care of ipmievd service fail

Steps to Reproduce:

I'm running ipmievd on a VM with no /dev/ipmi* device. 
Service ipmi is stopped: Now:

# service ipmievd start
Redirecting to /bin/systemctl  start ipmievd.service
# echo $?
0
# service ipmievd status
Redirecting to /bin/systemctl  status ipmievd.service
ipmievd.service - Ipmievd Daemon
          Loaded: loaded (/usr/lib/systemd/system/ipmievd.service; disabled)
          Active: failed (Result: exit-code) since Wed, 28 Mar 2012 11:45:00 -0400; 4s ago
         Process: 4854 ExecStart=/usr/sbin/ipmievd $IPMIEVD_OPTIONS (code=exited, status=1/FAILURE)
          CGroup: name=systemd:/system/ipmievd.service

Mar 28 11:45:00 dhcp-25-164.brq.redhat.com ipmievd[4854]: ipmievd: using pidfile /var/run/ipmievd.pid0
Mar 28 11:45:00 dhcp-25-164.brq.redhat.com ipmievd[4854]: Could not open device at /dev/ipmi0 or /dev/ipmi/0 or /dev/ipmidev/0: No such file or directory
#

Version-Release number of selected component (if applicable):

  ipmitool-1.8.11-9.fc17 

How reproducible:

  Always

 
Actual results:

  Service fails to start, but returns exitcode 0.

Expected results:

  Service fails to start, but returns non-zero exitcode.

Additional info:

  Maybe the forking type in the unit file would do the trick.

Comment 1 Fedora Update System 2012-04-26 10:30:10 UTC
ipmitool-1.8.11-10.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ipmitool-1.8.11-10.fc17

Comment 2 Fedora Update System 2012-05-04 22:18:52 UTC
Package ipmitool-1.8.11-10.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ipmitool-1.8.11-10.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-7336/ipmitool-1.8.11-10.fc17
then log in and leave karma (feedback).

Comment 3 Fedora Update System 2012-05-26 06:52:11 UTC
ipmitool-1.8.11-10.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 4 Martin Cermak 2012-06-05 12:01:47 UTC
Looks good, thanks for the fix!


Note You need to log in before you can comment on or make changes to this bug.