Bug 807766 - cimuser -l fails
cimuser -l fails
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: tog-pegasus (Show other bugs)
16
i686 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Vitezslav Crhonek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-28 12:22 EDT by Philippe Vouters
Modified: 2012-04-02 08:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-02 07:47:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philippe Vouters 2012-03-28 12:22:08 EDT
Description of problem:
# cimuser whichever option fails with:
Failed to list the users. 
CIM_ERR_NOT_SUPPORTED: PG_User

Version-Release number of selected component (if applicable):
Fedora 16 (tog-pegasus-2.11.1-1.fc16.i686)

How reproducible:
Always

Steps to Reproduce:
1. su -
2. You may have to yum install tog-pegasus
2. cimuser -a -u <your existing local login account> -w <any password>
3.
  
Actual results:
[root@victor ~]# cimuser -a -u philippe -w BetweenMeAndYou                      Failed to add user.
CIM_ERR_NOT_SUPPORTED: PG_User

Expected results:
# cimuser -l should list philippe

Additional info:
Regression with previous CIM versions unless I missed something. No man avail on cimuser. Prevents me from running http://vouters.dyndns.org/WBEMApp
No indication on the Web where to look at and cure this problem. Important note: This Fedora 16 computer is an upgrade since Fedora Core 4. So the informations contained on the disk have lived.
Comment 1 Vitezslav Crhonek 2012-04-02 07:47:48 EDT
PAM is used for OpenPegasus authentication in Fedora and you don't need to use cimuser command at all (OpenPegasus user management mechanism is automatically disabled when compiled with PAM support).

See /etc/Pegasus/access.conf for user management.
Comment 2 Philippe Vouters 2012-04-02 08:29:39 EDT
Thank you so much Red Hat for your response. PAM support was the change I was indeed missing. My http://vouters.dyndns.org/WBEMApp application now works again as expected. Instead of granting guest WBEM read access to /root/cimv2 via cimuser, I just had to do:
# cimauth -a -u guest -n root/cimv2 -R
and it did the trick.

Thank you so much for the high quality of your support.

Note You need to log in before you can comment on or make changes to this bug.