Bug 807802 - SELinux is preventing /usr/bin/qemu-kvm from 'create' accesses on the sock_file guadalinex-v8-desktop-i386-final.iso-4.monitor.
SELinux is preventing /usr/bin/qemu-kvm from 'create' accesses on the sock_fi...
Status: CLOSED DUPLICATE of bug 802551
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:325c5ed865a30b31021e5551ac4...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-28 14:45 EDT by Juanjo Marin
Modified: 2012-03-29 03:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-29 03:17:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juanjo Marin 2012-03-28 14:45:13 EDT
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.3.0-1.fc17.x86_64
reason:         SELinux is preventing /usr/bin/qemu-kvm from 'create' accesses on the sock_file guadalinex-v8-desktop-i386-final.iso-4.monitor.
time:           Wed 28 Mar 2012 08:44:48 PM CEST

description:
:SELinux is preventing /usr/bin/qemu-kvm from 'create' accesses on the sock_file guadalinex-v8-desktop-i386-final.iso-4.monitor.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that qemu-kvm should be allowed create access on the guadalinex-v8-desktop-i386-final.iso-4.monitor sock_file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep qemu-kvm /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:svirt_t:s0:c695,c709
:Target Context                system_u:object_r:virt_home_t:s0:c695,c709
:Target Objects                guadalinex-v8-desktop-i386-final.iso-4.monitor [
:                              sock_file ]
:Source                        qemu-kvm
:Source Path                   /usr/bin/qemu-kvm
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           qemu-system-x86-1.0-6.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-104.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.0-1.fc17.x86_64 #1 SMP
:                              Mon Mar 19 03:03:39 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    Wed 28 Mar 2012 08:44:07 PM CEST
:Last Seen                     Wed 28 Mar 2012 08:44:07 PM CEST
:Local ID                      c21b7580-909e-415c-a858-fdcb66e9bb12
:
:Raw Audit Messages
:type=AVC msg=audit(1332960247.524:168): avc:  denied  { create } for  pid=9945 comm="qemu-kvm" name="guadalinex-v8-desktop-i386-final.iso-4.monitor" scontext=system_u:system_r:svirt_t:s0:c695,c709 tcontext=system_u:object_r:virt_home_t:s0:c695,c709 tclass=sock_file
:
:
:type=SYSCALL msg=audit(1332960247.524:168): arch=x86_64 syscall=bind success=no exit=EACCES a0=3 a1=7fff6c4d1b10 a2=6e a3=7f3292bb9e9a items=0 ppid=1 pid=9945 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=2 comm=qemu-kvm exe=/usr/bin/qemu-kvm subj=system_u:system_r:svirt_t:s0:c695,c709 key=(null)
:
:Hash: qemu-kvm,svirt_t,virt_home_t,sock_file,create
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Daniel Walsh 2012-03-28 14:59:52 EDT
Did you launch from libvirt?  

Is it trying to create a sock file in 

~/.libvirt
~/.virtinst
~/VirtualMachines
Comment 2 Miroslav Grepl 2012-03-29 03:17:38 EDT

*** This bug has been marked as a duplicate of bug 802551 ***

Note You need to log in before you can comment on or make changes to this bug.