Bug 807821 - (ns3) Review request: ns-3 Network Simulator
Review request: ns-3 Network Simulator
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Nobody's working on this, feel free to take it
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2012-03-28 16:10 EDT by Vedran Miletić
Modified: 2015-12-11 11:17 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2015-12-11 11:17:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
ns-3.16 RPM spec file (116.04 KB, text/x-rpm-spec)
2012-12-29 09:34 EST, Vedran Miletić
no flags Details
Required patches (20.00 KB, application/x-tar)
2012-12-29 09:36 EST, Vedran Miletić
no flags Details
ns-3.16 RPM spec file (116.04 KB, text/x-matlab)
2015-02-01 16:49 EST, Vedran Miletić
no flags Details

  None (edit)
Description Vedran Miletić 2012-03-28 16:10:21 EDT
This is F17 feature: http://fedoraproject.org/wiki/Features/Ns3

We are a bit late on the schedule because of coordination with upstream regarding building with GCC 4.7. It should mostly work now. Since this is not an invasive change, it shouldn't be a problem.

Package wise, ns-3 is a C++ library; aside from the fact that upstream requested versioned SONAMEs and packaging both debug and optimized libs, there is not much special stuff to see here.

I would like some general comments on the approach and structure. I know that specfile isn't ready for inclusion since too much is commented out and it needs substantial cleanup; I'm aware of that, that's the easy part that I will do once I get green light on this approach to packaging.

Be warned, since we are still packaging pre-relase stuff, the source code archive is quite large since it contains hg/bzr repodata. This will definitely be sorted out before inclusion.

spec: http://inf2.ffri.hr/~vedranm/ns3fedora17/SPECS/
SRPM: http://inf2.ffri.hr/~vedranm/ns3fedora17/SRPMS/
x86_64 RPM: http://inf2.ffri.hr/~vedranm/ns3fedora17/RPMS/x86_64/
Comment 1 Reiner Rottmann 2012-07-13 10:06:46 EDT
Above links are broken.

As no SRPM is available, I've downloaded the ns3 spec file from the F17 feature page and the source code mentioned in the spec file.

The rpmbuild fails:

Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
Requires: libatk-1.0.so.0()(64bit) libc.so.6()(64bit) libc.so.6(GLIBC_2.2.5)(64bit) libcairo.so.2()(64bit) libfontconfig.so.1()(64bit) libfreetype.so.6()(64bit) libgcc_s.so.1()(64bit) libgcc_s.so.1(GCC_3.0)(64bit) libgdk-x11-2.0.so.0()(64bit) libgdk_pixbuf-2.0.so.0()(64bit) libgio-2.0.so.0()(64bit) libglib-2.0.so.0()(64bit) libgobject-2.0.so.0()(64bit) libgsl.so.0()(64bit) libgslcblas.so.0()(64bit) libgtk-x11-2.0.so.0()(64bit) libm.so.6()(64bit) libns3.14-antenna-optimized.so()(64bit) libns3.14-aodv-optimized.so()(64bit) libns3.14-applications-optimized.so()(64bit) libns3.14-bridge-optimized.so()(64bit) libns3.14-buildings-optimized.so()(64bit) libns3.14-config-store-optimized.so()(64bit) libns3.14-core-optimized.so()(64bit) libns3.14-csma-layout-optimized.so()(64bit) libns3.14-csma-optimized.so()(64bit) libns3.14-dsdv-optimized.so()(64bit) libns3.14-emu-optimized.so()(64bit) libns3.14-energy-optimized.so()(64bit) libns3.14-flow-monitor-optimized.so()(64bit) libns3.14-internet-optimized.so()(64bit) libns3.14-lte-optimized.so()(64bit) libns3.14-mesh-optimized.so()(64bit) libns3.14-mobility-optimized.so()(64bit) libns3.14-mpi-optimized.so()(64bit) libns3.14-netanim-optimized.so()(64bit) libns3.14-network-optimized.so()(64bit) libns3.14-nix-vector-routing-optimized.so()(64bit) libns3.14-olsr-optimized.so()(64bit) libns3.14-point-to-point-layout-optimized.so()(64bit) libns3.14-point-to-point-optimized.so()(64bit) libns3.14-propagation-optimized.so()(64bit) libns3.14-spectrum-optimized.so()(64bit) libns3.14-stats-optimized.so()(64bit) libns3.14-tap-bridge-optimized.so()(64bit) libns3.14-test-optimized.so()(64bit) libns3.14-tools-optimized.so()(64bit) libns3.14-topology-read-optimized.so()(64bit) libns3.14-uan-optimized.so()(64bit) libns3.14-virtual-net-device-optimized.so()(64bit) libns3.14-wifi-optimized.so()(64bit) libns3.14-wimax-optimized.so()(64bit) libpango-1.0.so.0()(64bit) libpangocairo-1.0.so.0()(64bit) libpangoft2-1.0.so.0()(64bit) libpthread.so.0()(64bit) libpthread.so.0(GLIBC_2.2.5)(64bit) libpython2.7.so.1.0()(64bit) librt.so.1()(64bit) libsqlite3.so.0()(64bit) libstdc++.so.6()(64bit) libstdc++.so.6(CXXABI_1.3)(64bit) libstdc++.so.6(GLIBCXX_3.4)(64bit) libxml2.so.2()(64bit) python(abi) = 2.7 rtld(GNU_HASH)
Processing files: ns-core-3.14-0.1hg7804.fc17.x86_64
Provides: libns3.14-core-debug.so()(64bit) libns3.14-core-optimized.so()(64bit) pkgconfig(libns3.14-core-debug) = 3.14 pkgconfig(libns3.14-core-optimized) = 3.14
Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
Requires(post): /sbin/ldconfig
Requires(postun): /sbin/ldconfig
Requires: /usr/bin/pkg-config libc.so.6()(64bit) libc.so.6(GLIBC_2.14)(64bit) libc.so.6(GLIBC_2.2.5)(64bit) libgcc_s.so.1()(64bit) libgcc_s.so.1(GCC_3.0)(64bit) libgsl.so.0()(64bit) libgslcblas.so.0()(64bit) libm.so.6()(64bit) libm.so.6(GLIBC_2.2.5)(64bit) libpthread.so.0()(64bit) libpthread.so.0(GLIBC_2.2.5)(64bit) libpthread.so.0(GLIBC_2.3.2)(64bit) librt.so.1()(64bit) librt.so.1(GLIBC_2.2.5)(64bit) libstdc++.so.6()(64bit) libstdc++.so.6(CXXABI_1.3)(64bit) libstdc++.so.6(GLIBCXX_3.4)(64bit) libstdc++.so.6(GLIBCXX_3.4.11)(64bit) libstdc++.so.6(GLIBCXX_3.4.15)(64bit) libstdc++.so.6(GLIBCXX_3.4.9)(64bit) rtld(GNU_HASH)
Processing files: ns-core-devel-3.14-0.1hg7804.fc17.x86_64
error: File not found: /home/rottmrei/rpmbuild/BUILDROOT/ns-3.14-0.1hg7804.fc17.x86_64/usr/include/ns3.14/ns3/ns2-calendar-scheduler.h

RPM build errors:
    File not found: /home/rottmrei/rpmbuild/BUILDROOT/ns-3.14-0.1hg7804.fc17.x86_64/usr/include/ns3.14/ns3/ns2-calendar-scheduler.h
Comment 2 Vedran Miletić 2012-07-16 06:26:02 EDT
Sorry Reiner, I this was ignored for a long time and I forgot to update it.

Anyway, specfile is now updated and can be found here: http://www.inf.uniri.hr/~vmiletic/ns-3/ns.spec
Comment 3 Mario Blättermann 2012-08-26 17:02:32 EDT
(In reply to comment #2)
> http://www.inf.uniri.hr/~vmiletic/ns-3/ns.spec

The link is dead. Don't know if temporarily, but no connection to that server can be established, you should have a look at it. Moreover, you should also provide a srpm.

I can't find your name or mail address in the packagers group, are you a new packager and need a sponsor?
Comment 4 Mario Blättermann 2012-09-16 13:32:50 EDT
Adding FE-NEEDSPONSOR. Please remove it once you are sponsored.
Comment 5 Vedran Miletić 2012-12-29 09:34:26 EST
Created attachment 670114 [details]
ns-3.16 RPM spec file

Massive update for 3.16.
Comment 6 Vedran Miletić 2012-12-29 09:36:24 EST
Created attachment 670115 [details]
Required patches
Comment 7 Robin Lee 2013-02-26 23:41:12 EST
SRPM is required for package review. Dropbox is even a choice for SPEC and SRPM hosting.

I tried to build the RPM on Fedora 18 x86_64, but finally it failed with:

RPM build errors:
    File not found: /home/cheese/rpmbuild/BUILDROOT/ns-3.16-1.fc18.x86_64/usr/lib64/libnsc0.5.3-linux2.6.18.so
    File not found: /home/cheese/rpmbuild/BUILDROOT/ns-3.16-1.fc18.x86_64/usr/lib64/libnsc0.5.3-linux2.6.26.so
Comment 8 Christopher Meng 2013-07-29 22:58:15 EDT
Well, from 17->20, this feature still not implemented yet.

I require this package, too.
Comment 9 Vedran Miletić 2013-07-30 02:36:00 EDT
Christopher, it is true, it wasn't pushed into Fedora. However, biggest part of the job is done. Are you willing to take over and do the rest? Unfortunately I don't have time to finish it now.
Comment 10 Christopher Meng 2013-07-31 02:37:18 EDT
I may have a try, but can you provide your spec/SRPM?
Comment 11 Vedran Miletić 2013-08-04 04:19:56 EDT
(In reply to Christopher Meng from comment #10)
> I may have a try, but can you provide your spec/SRPM?

Both are here: http://inf2.uniri.hr/~vedranm/ns3fedora/

Most of the plumbing work has been done, but it needs an update to ns-3.17, review against the guidelines, and a lot of testing.

Feel free to finish it and push it.
Comment 12 Christopher Meng 2013-08-05 01:00:44 EDT

But this depends on my spare time.

Comment 13 Vedran Miletić 2015-02-01 16:49:25 EST
Created attachment 986850 [details]
ns-3.16 RPM spec file

This is the latest version of spec file I produced back in 2013. I'm just posting it here in case anyone wants to resume work.

I might need this in April-May timeframe, so if noone takes over I could do it myself. No promises however.
Comment 14 James Hogarth 2015-12-03 23:03:30 EST
Vedran are you interested in picking this back up again?

If not let's close it as a dead review so that others can see it's not in active progression and can open a fresh ticket if they are interested.
Comment 15 James Hogarth 2015-12-11 11:17:10 EST
It's been over a week with no response from the requestor to the NeedsInfo flag.

Closing as per policy.

Note You need to log in before you can comment on or make changes to this bug.