This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 807856 - SELinux is preventing /usr/sbin/groupmod from 'rename' accesses on the file group+.
SELinux is preventing /usr/sbin/groupmod from 'rename' accesses on the file g...
Status: CLOSED DUPLICATE of bug 809735
Product: Fedora
Classification: Fedora
Component: shadow-utils (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Vrabec
Fedora Extras Quality Assurance
abrt_hash:d42265f13b3f36a06323fd343bd...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-28 19:25 EDT by Tom
Modified: 2012-04-04 11:43 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-04 11:43:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
yum update history (6.77 KB, text/plain)
2012-03-30 12:28 EDT, Tom
no flags Details

  None (edit)
Description Tom 2012-03-28 19:25:05 EDT
libreport version: 2.0.10
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.4.0-0.rc0.git1.2.fc18.x86_64
time:           Wed 28 Mar 2012 07:23:38 PM EDT

description:
:SELinux is preventing /usr/sbin/groupmod from 'rename' accesses on the file group+.
:
:*****  Plugin catchall_labels (83.8 confidence) suggests  ********************
:
:If you want to allow groupmod to have rename access on the group+ file
:Then you need to change the label on group+
:Do
:# semanage fcontext -a -t FILE_TYPE 'group+'
:where FILE_TYPE is one of the following: pcscd_var_run_t, shadow_t, passwd_file_t. 
:Then execute: 
:restorecon -v 'group+'
:
:
:*****  Plugin catchall (17.1 confidence) suggests  ***************************
:
:If you believe that groupmod should be allowed rename access on the group+ file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep groupmod /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:system_r:groupadd_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:etc_t:s0
:Target Objects                group+ [ file ]
:Source                        groupmod
:Source Path                   /usr/sbin/groupmod
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           shadow-utils-4.1.5-2.fc18.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-104.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.4.0-0.rc0.git1.2.fc18.x86_64 #1
:                              SMP Thu Mar 22 21:38:33 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    Wed 28 Mar 2012 07:21:04 PM EDT
:Last Seen                     Wed 28 Mar 2012 07:21:04 PM EDT
:Local ID                      0eae47a1-d914-48be-a926-a9d69f934f39
:
:Raw Audit Messages
:type=AVC msg=audit(1332976864.287:71): avc:  denied  { rename } for  pid=2382 comm="groupmod" name="group+" dev="dm-2" ino=1313961 scontext=unconfined_u:system_r:groupadd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:etc_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1332976864.287:71): arch=x86_64 syscall=rename success=yes exit=0 a0=7fff47681850 a1=7f492795a100 a2=7fff476817c0 a3=7f49270e57b8 items=0 ppid=2376 pid=2382 auid=1000 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=pts1 ses=1 comm=groupmod exe=/usr/sbin/groupmod subj=unconfined_u:system_r:groupadd_t:s0-s0:c0.c1023 key=(null)
:
:Hash: groupmod,groupadd_t,etc_t,file,rename
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Miroslav Grepl 2012-03-29 03:04:28 EDT
Peter,
does it relate to the issue which we have been discussing?

We have labels for

/etc/group-
/etc/group
Comment 2 Peter Vrabec 2012-03-30 07:13:40 EDT
I can't reproduce this issue. 

Tom, could you send me the command that you tried to execute please. What version of shadow-utils is it? I'm using shadow-utils-4.1.5-2.
Comment 3 Tom 2012-03-30 12:28:16 EDT
Created attachment 574037 [details]
yum update history
Comment 4 Tom 2012-03-30 12:30:49 EDT
I got this selinux warning while doing yum update. I also have shadow-utils-4.1.5-2.fc18.
Comment 5 Peter Vrabec 2012-04-04 11:43:57 EDT

*** This bug has been marked as a duplicate of bug 809735 ***

Note You need to log in before you can comment on or make changes to this bug.