Bug 807860 - Apache hang on kernel 2.6.18-308.1.1.el5 with large StartServers and low MaxSpareServers [NEEDINFO]
Apache hang on kernel 2.6.18-308.1.1.el5 with large StartServers and low MaxS...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.8
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-28 19:53 EDT by ryanfox
Modified: 2014-06-02 09:05 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:05:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (ryanfox)


Attachments (Terms of Use)

  None (edit)
Description ryanfox 2012-03-28 19:53:10 EDT
Description of problem:
	I am able to reliably reproduce an Apache hang (clients connect and wait forever for response) using these prefork mpm settings and kernel 2.6.18-308.1.1.el5. Booting off an earlier kernel (kernel-2.6.18-274.12.1.el5) allows this to work as expected.


Version-Release number of selected component (if applicable):
RH 5.8
kernel-2.6.18-308.1.1.el5
httpd-2.2.3-63.el5


How reproducible:
always


Steps to Reproduce:
httpd.conf

<IfModule prefork.c>
StartServers 1024
MinSpareServers 5
MaxSpareServers 20
ServerLimit 1024
MaxClients 1024
MaxRequestsPerChild 4000
</IfModule>

apachectl restart
while [ 1 == 1 ]; do curl -s http://localhost -o /dev/null; done


Actual results:
After several minutes, apache stops responding to requests. (Unresponsive state occurs naturally after about 10 minutes, but above curl loop speeds up the process to just a few)


Expected results:
requests are served quickly


Additional info:
Comment 1 Richard Karhuse 2012-05-25 16:13:48 EDT
Seeing the same issue.

CaseID:  00647579 

Also, see bug:  https://bugzilla.redhat.com/show_bug.cgi?id=681578

Some other info from the Net for Apache:  http://bugs.centos.org/view.php?id=5634
Comment 2 RHEL Product and Program Management 2014-03-07 07:42:04 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 3 RHEL Product and Program Management 2014-06-02 09:05:19 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.