This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 807862 - Failed to create jenkins app
Failed to create jenkins app
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Rob Millner
Chandrika Gole
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-28 20:12 EDT by Chandrika Gole
Modified: 2015-05-14 21:49 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-13 14:32:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
broker log (16.84 KB, application/octet-stream)
2012-03-28 20:12 EDT, Chandrika Gole
no flags Details

  None (edit)
Description Chandrika Gole 2012-03-28 20:12:21 EDT
Created attachment 573493 [details]
broker log

Description of problem:

Tried to create a non-scalable jenkins app 
$ curl -k -X POST -H 'Accept: application/xml' -d name=myapp -d
cartridge=jenkins-1.4 --user cgole:foo
https://ip/broker/rest/domains/cgole/applications

<h1>Proxy Error</h1>
<p>The proxy server received an invalid
response from an upstream server.<br />
The proxy server could not handle the request <em><a href="/broker/rest/domains/cgole2xx/applications">POST&nbsp;/broker/rest/domains/cgole2xx/applications</a></em>.<p>
Reason: <strong>Error reading from remote server</strong></p></p>
<hr>

Attaching broker logs - 


Version-Release number of selected component (if applicable):
devenv_1677
rhc-0.89.7-1.el6_2.noarch
broker-0.89.4-1.el6_2.noarch
c--10gen-mms-agent-0.1-1.7.1-1.el6_2.noarch 
c--jenkins-1.4-0.89.2-1.el6_2.noarch 


How reproducible:
always

Steps to Reproduce:
1. Create a jenkins app.
curl -k -X POST -H 'Accept: application/xml' -d name=myapp -d
cartridge=jenkins-1.4 --user cgole:foo
https://ip/broker/rest/domains/cgole/applications

Actual results:
Fail to create jenkins app. I am able to create a php app using the same curl command on the same instance and that was successful.


Expected results:
Jenkins app should be created successfully/.

Additional info:
Comment 1 Rob Millner 2012-03-28 22:53:24 EDT
Can't reproduce on devenv_1679.

$ curl -k -u 'rmillner:none' -X POST -H 'Accept: application/xml' -d name=myapp -d cartridge=jenkins-1.4  https://184.73.41.95/broker/rest/domains/rmillner0007/applications

<?xml version="1.0" encoding="UTF-8"?>
<response>
  <status>created</status>
  <type>application</type>
  <version>1.0</version>
...
</response>



$ curl -k -u 'rmillner:none' -X POST -H 'Accept: application/xml' -d name=myrealapp -d cartridge=php-5.3  https://184.73.41.95/broker/rest/domains/rmillner0007/applications

<?xml version="1.0" encoding="UTF-8"?>
<response>
  <status>created</status>
  <type>application</type>
  <version>1.0</version>
...
</response>
Comment 2 Rob Millner 2012-03-28 23:00:30 EDT
Verified with the CLI tools.

$ rhc app create -p none -a myapp -t php-5.3 --enable-jenkins
Creating application: jenkins in rmillner0007
Now your new domain name is being propagated worldwide (this might take a minute)...
...
Successfully created application: myapp

$ cd myapp; echo "" >> README ; git commit -a -m 'foo'; git push
...
remote: SUCCESS
remote: New build has been deployed.
To ssh://04163c2cfae04e26b2badde458a9d569@myapp-rmillner0007.dev.rhcloud.com/~/git/myapp.git/
   62b0fb8..7d8e603  master -> master
Comment 3 Xiaoli Tian 2012-03-30 06:45:41 EDT
Verified it on devenv-stage_154, it works.

Note You need to log in before you can comment on or make changes to this bug.