Bug 807872 - SELinux is preventing /usr/bin/qemu-kvm from 'write' accesses on the directory lib.
SELinux is preventing /usr/bin/qemu-kvm from 'write' accesses on the director...
Status: CLOSED DUPLICATE of bug 802551
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:292ea9b54cf15a5f8fe79318e23...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-28 21:29 EDT by Paul W. Frields
Modified: 2012-03-29 03:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-29 03:17:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul W. Frields 2012-03-28 21:29:56 EDT
libreport version: 2.0.10
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.3.0-5.fc17.x86_64
time:           Wed 28 Mar 2012 09:27:14 PM EDT

description:
:SELinux is preventing /usr/bin/qemu-kvm from 'write' accesses on the directory lib.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that qemu-kvm should be allowed write access on the lib directory by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep qemu-kvm /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:svirt_t:s0:c248,c766
:Target Context                unconfined_u:object_r:virt_home_t:s0
:Target Objects                lib [ dir ]
:Source                        qemu-kvm
:Source Path                   /usr/bin/qemu-kvm
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           qemu-system-x86-1.0-6.fc17.x86_64
:Target RPM Packages           filesystem-3-2.fc17.x86_64
:Policy RPM                    selinux-policy-3.10.0-106.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.0-5.fc17.x86_64 #1 SMP Fri Mar
:                              23 20:10:36 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    Wed 28 Mar 2012 09:21:03 PM EDT
:Last Seen                     Wed 28 Mar 2012 09:21:03 PM EDT
:Local ID                      a05dfe91-3d2a-4102-bb6a-95e133e5f29d
:
:Raw Audit Messages
:type=AVC msg=audit(1332984063.941:378): avc:  denied  { write } for  pid=3792 comm="qemu-kvm" name="lib" dev="dm-12" ino=4725285 scontext=system_u:system_r:svirt_t:s0:c248,c766 tcontext=unconfined_u:object_r:virt_home_t:s0 tclass=dir
:
:
:type=SYSCALL msg=audit(1332984063.941:378): arch=x86_64 syscall=bind success=no exit=EACCES a0=3 a1=7fff5d4370e0 a2=6e a3=7fdf02560e99 items=0 ppid=1 pid=3792 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=5 comm=qemu-kvm exe=/usr/bin/qemu-kvm subj=system_u:system_r:svirt_t:s0:c248,c766 key=(null)
:
:Hash: qemu-kvm,svirt_t,virt_home_t,dir,write
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Miroslav Grepl 2012-03-29 03:17:26 EDT

*** This bug has been marked as a duplicate of bug 802551 ***

Note You need to log in before you can comment on or make changes to this bug.