Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 807896 - Wifi signal drops for a few seconds then comes back up randomly all day
Summary: Wifi signal drops for a few seconds then comes back up randomly all day
Keywords:
Status: CLOSED DUPLICATE of bug 785772
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 16
Hardware: i686
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-03-29 05:16 UTC by Tim Kitsos
Modified: 2012-05-02 06:35 UTC (History)
8 users (show)

Fixed In Version: selinux-policy-3.10.0-84.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-02 06:35:37 UTC
Type: ---


Attachments (Terms of Use)
Message Log 3/27/12 (3.36 MB, text/plain)
2012-03-29 05:16 UTC, Tim Kitsos
no flags Details
var/log/messages (1.47 MB, text/plain)
2012-04-25 02:08 UTC, Tim Kitsos
no flags Details
ausearch -m avc (24.84 KB, text/plain)
2012-04-25 15:36 UTC, Tim Kitsos
no flags Details
rpm-qa selinux-policy and other commands (3.30 KB, text/plain)
2012-04-25 23:43 UTC, Tim Kitsos
no flags Details
Screen shot of current error. png file (74.42 KB, image/png)
2012-04-26 23:27 UTC, Tim Kitsos
no flags Details
var/log/messages to go along with Screen Shot error photo (1.14 MB, text/plain)
2012-04-26 23:29 UTC, Tim Kitsos
no flags Details
ausearch -m avc 04/27/12 (24.94 KB, text/plain)
2012-04-27 19:31 UTC, Tim Kitsos
no flags Details

Description Tim Kitsos 2012-03-29 05:16:08 UTC
Created attachment 573529 [details]
Message Log 3/27/12

Description of problem:
Up and running on internet then a Banner shows up: "Connection Failed  Activation of network connection failed." Wifi signal drops for a few seconds then comes back up. Does this randomly all day. Just started doing this in last week or 2.

Version-Release number of selected component (if applicable):
Fedora 16 32 bit(DVD install not upgrade) 3.3.0-4.fc16.i686.PAE GNOME 3.2.1 file system ext4

How reproducible:


Steps to Reproduce:
1.User log in with wifi
2.Browse internet
3.Fail banner shows up randomly
  
Actual results: wifi goes down then start back up - repeats randomly


Expected results: wifi should stay up.


Additional info:


Up and running on internet then a Banner shows up: "Connection Failed  Activation of network connection failed." Wifi signal drop for a few second then comes back up. Does this randomly all day. Just started doing this in last week or 2.

Text mode:3/28/12 [7565.323054] ICMPv6 RA: ndisc_router_discovery() failed to add default route.

Fedora 16 32 bit(DVD install not upgrade) 3.3.0-4.fc16.i686.PAE GNOME 3.2.1 file system ext4
HP Pavilion dv2617us Notebook 1.50 GHz Centrino Duo Core 2 T5250 2MB
Intel PRO/Wireless 3945ABG Network Connection Intel® 965GM

[tim@localhost ~]$ lspci -vvnn | grep -A 15 Network
07:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection [8086:4222] (rev 02)
	Subsystem: Hewlett-Packard Company Device [103c:135b]
	Physical Slot: 5
	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx+
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0, Cache Line Size: 64 bytes
	Interrupt: pin A routed to IRQ 47
	Region 0: Memory at f4300000 (32-bit, non-prefetchable) [size=4K]
	Capabilities: <access denied>
	Kernel driver in use: iwl3945
	Kernel modules: iwl3945

08:09.0 FireWire (IEEE 1394) [0c00]: Ricoh Co Ltd R5C832 IEEE 1394 Controller [1180:0832] (rev 05) (prog-if 10 [OHCI])
	Subsystem: Hewlett-Packard Company Device [103c:30cd]
	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
[tim@localhost ~]$ nmcli -f general dev list iface wlan0
GENERAL.DEVICE:                         wlan0
GENERAL.TYPE:                           802-11-wireless
GENERAL.DRIVER:                         iwl3945
GENERAL.HWADDR:                         00:1C:BF:27:B4:3A
GENERAL.STATE:                          connected
[tim@localhost ~]$ rpm -q kernel
package kernel is not installed
[tim@localhost ~]$ rpm --query --all 'kernel*'
kernel-devel-3.2.10-3.fc16.i686
kernel-devel-3.3.0-4.fc16.i686
kernel-PAE-3.2.10-3.fc16.i686
kernel-PAE-3.2.9-2.fc16.i686
kernel-headers-3.3.0-4.fc16.i686
kernel-devel-3.2.9-2.fc16.i686
kernel-PAE-3.3.0-4.fc16.i686
[tim@localhost ~]$

Comment 1 Jirka Klimes 2012-03-30 10:07:40 UTC
What NetworkManager version do you use? Did you have issues with previous kernels?

Does it help if you upgrade NM?
Latest one (not in stable yet) is
https://admin.fedoraproject.org/updates/NetworkManager-0.9.4-1.git20120328.fc16?_csrf_token=6cea0d26533cab7789ce8d811d01006477fe45d7

Comment 2 Tim Kitsos 2012-03-31 19:42:33 UTC
1:0.9.2-1.fc16 (32bit)Network Manager updated on 12/14/2011
3.2.3-1.fc16 (32bit) evolution-NetworkManager updated on 3/18/2012 (I don't knowingly use Evolution.)

I basically have a up to date stock system with Adobe Flash and Google Chrome.
AT&T DSL  Google DNS
I've used Fedora from day one and this problem just started in March 2012.



[tim@localhost ~]$ rpm -q NetworkManager
NetworkManager-0.9.2-1.fc16.i686
[tim@localhost ~]$ rpm -q evolution-NetworkManager
evolution-NetworkManager-3.2.3-2.fc16.i686
[tim@localhost ~]$ 

Thanks for your help.

Comment 3 Tim Kitsos 2012-03-31 19:44:20 UTC
I did not have problems with previous kernels.

Comment 4 Tim Kitsos 2012-03-31 20:03:20 UTC
Upgraded per your request. Will let you know what happens. Thanks again.

[tim@localhost ~]$ rpm -q NetworkManager
NetworkManager-0.9.4-1.git20120328.fc16.i686
[tim@localhost ~]$ rpm -q evolution-NetworkManager
evolution-NetworkManager-3.2.3-2.fc16.i686
[tim@localhost ~]$

Comment 5 Tim Kitsos 2012-03-31 20:25:54 UTC
It just failed again with new upgrade Network Manager. Went down came back up, same as before.

Comment 6 Tim Kitsos 2012-04-02 23:18:52 UTC
I believe this is related to above. 

SELinux is preventing /usr/sbin/NetworkManager from read access on the file /etc/sysctl.conf.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that NetworkManager should be allowed read access on the sysctl.conf file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep NetworkManager /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:NetworkManager_t:s0
Target Context                system_u:object_r:system_conf_t:s0
Target Objects                /etc/sysctl.conf [ file ]
Source                        NetworkManager
Source Path                   /usr/sbin/NetworkManager
Port                          <Unknown>
Host                          localhost.localdomain
Source RPM Packages           
Target RPM Packages           initscripts-9.34.2-1.fc16.i686
Policy RPM                    selinux-policy-3.10.0-80.fc16.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     localhost.localdomain
Platform                      Linux localhost.localdomain 3.3.0-4.fc16.i686.PAE
                              #1 SMP Tue Mar 20 18:24:16 UTC 2012 i686 i686
Alert Count                   16
First Seen                    Sat 31 Mar 2012 12:52:13 PM PDT
Last Seen                     Mon 02 Apr 2012 03:59:38 PM PDT
Local ID                      29f4d6a3-9807-4e09-95f9-863a0fb5a3f5

Raw Audit Messages
type=AVC msg=audit(1333407578.729:114): avc:  denied  { read } for  pid=871 comm="NetworkManager" name="sysctl.conf" dev="dm-1" ino=656214 scontext=system_u:system_r:NetworkManager_t:s0 tcontext=system_u:object_r:system_conf_t:s0 tclass=file


Hash: NetworkManager,NetworkManager_t,system_conf_t,file,read

audit2allow

#============= NetworkManager_t ==============
allow NetworkManager_t system_conf_t:file read;

audit2allow -R

#============= NetworkManager_t ==============
allow NetworkManager_t system_conf_t:file read;

Comment 7 Jirka Klimes 2012-04-04 08:24:59 UTC
Reassigning to selinux-policy, so that policy can be updated.

Yeah, NetworkManager read /etc/sysctl.conf or /lib/sysctl.d/sysctl.conf to
get net.ipv6.conf.default.use_tempaddr (for IPv6 Privacy Extensions)

/* Read file contents to a string. */
if (!g_file_get_contents ("/etc/sysctl.conf", &contents, &len, NULL))
  if (!g_file_get_contents ("/lib/sysctl.d/sysctl.conf", &contents, &len, NULL))
    return -1;

Comment 8 Miroslav Grepl 2012-04-04 08:53:02 UTC
Fixed in selinux-policy-3.10.0-82.fc16

Comment 9 Tim Kitsos 2012-04-06 03:43:10 UTC
Thanks, will update to selinux-policy -82 when available.

Comment 10 Fedora Update System 2012-04-18 12:55:35 UTC
selinux-policy-3.10.0-84.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/selinux-policy-3.10.0-84.fc16

Comment 11 Fedora Update System 2012-04-22 03:37:52 UTC
selinux-policy-3.10.0-84.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Tim Kitsos 2012-04-24 04:57:53 UTC
Upgraded to selinux-policy-3.10.0-84.fc16 , but still have same problem.

Description of problem:
Up and running on internet then a Banner shows up: "Connection Failed 
Activation of network connection failed." Wifi signal drops for a few seconds
then comes back up. Does this randomly. The only thing now there is no record in selinux of the error. Selinux alert browser says no alerts, even after banner show up on bottom of screen. No icon in bottom right corner of screen to show record of error.

Comment 13 Daniel Walsh 2012-04-24 15:02:28 UTC
Could you attach your latest AVC's

Comment 14 Tim Kitsos 2012-04-25 02:08:55 UTC
Created attachment 580042 [details]
var/log/messages

var/log/messages

Hope, this is what you want. If not let me know.

Comment 15 Miroslav Grepl 2012-04-25 11:21:10 UTC
Does it work in permissive mode?

$ setenforce 0

re-test

$ ausearch -m avc -ts recent
$ setenforce 1

Comment 16 Tim Kitsos 2012-04-25 15:36:13 UTC
Created attachment 580196 [details]
ausearch -m avc

Will get back to you on if it works in permissive mode?

Comment 17 Miroslav Grepl 2012-04-25 20:37:03 UTC
what does

$ rpm -qa selinux-policy*
$ yum reinstall selinux-policy-targeted
$ sesearch -A -s NetworkManager_t -t system_conf_t

Comment 18 Tim Kitsos 2012-04-25 23:43:01 UTC
Created attachment 580303 [details]
rpm-qa selinux-policy and other commands

Problem is still happening under permissive mode. Did reinstall.  Wasn't able to do sesearch command. Did other commands. See attached file.

Comment 19 Miroslav Grepl 2012-04-26 09:47:27 UTC
sesearch command is a part of the setools-console package

$ rpm -qf `which sesearch`
setools-console-3.3.7-11.fc14.x86_64

Try the following

$ yum update selinux-policy-targeted --enablerepo=updates-testing

Comment 20 Daniel Walsh 2012-04-26 13:41:18 UTC
If it is happening in permissive mode it is most likely not SELinux related.

Comment 21 Tim Kitsos 2012-04-26 20:39:09 UTC
[tim@localhost ~]$ sesearch -A -s NetworkManager_t -t system_conf_t
Found 3 semantic av rules:
   allow NetworkManager_t file_type : filesystem getattr ; 
   allow NetworkManager_t system_conf_t : file { ioctl read getattr lock open } ; 
   allow NetworkManager_t system_conf_t : lnk_file { read getattr } ; 

[tim@localhost ~]$

Comment 22 Tim Kitsos 2012-04-26 20:48:25 UTC
Did $ yum update selinux-policy-targeted --enablerepo=updates-testing


[root@localhost ~]# rpm -qa selinux-policy*
selinux-policy-targeted-3.10.0-86.fc16.noarch
selinux-policy-3.10.0-86.fc16.noarch
[root@localhost ~]# 


Failed after above, but I didn't log out or restart yet.

Comment 23 Tim Kitsos 2012-04-26 23:27:21 UTC
Created attachment 580600 [details]
Screen shot of current error.  png file

png file photo shows error banner at bottom of screen and loss of wifi connection at top of screen.

Comment 24 Tim Kitsos 2012-04-26 23:29:42 UTC
Created attachment 580601 [details]
var/log/messages to go along with Screen Shot error photo

Comment 25 Daniel Walsh 2012-04-27 14:48:01 UTC
Are you getting any additional AVC messages?  Does it connect in permissive mode.

ausearch -m avc -ts recent

Comment 26 Tim Kitsos 2012-04-27 19:31:24 UTC
Created attachment 580845 [details]
ausearch -m avc 04/27/12

Does it connect in permissive mode? Yes, Wifi connects than signal drops for a few seconds then comes back up randomly all day. It seems to stay connected longer but still disconnects and reconnects randomly all day. It's very quick the banner error box comes up on bottom of screen and the signal drops and within a minute or 2 it connected again.

Are you getting any additional AVC messages? I attached AVC message file. It look like there are no message after 4/23/12. My comment #12 (4/24/12) "The only thing now there is no record in selinux of the error. Selinux alert browser says no alerts, even after banner show up on bottom of screen. No icon in bottom right corner of screen to show record of error." Prior to 4/23/12 and icon would show up in right hand corner with alert information and would be in Selinux alert browser.

Maybe this is back to a Network Manager problem again, like we started with?

Comment 27 Miroslav Grepl 2012-04-28 06:26:18 UTC
These AVC are old and has been fixed. It looks like NM problem.

Comment 28 Tim Kitsos 2012-04-28 17:08:33 UTC
[tim@localhost ~]$ rpm -q NetworkManager
NetworkManager-0.9.4-2.git20120403.fc16.i686
[tim@localhost ~]$ rpm -q evolution-NetworkManager
evolution-NetworkManager-3.2.3-2.fc16.i686
[tim@localhost ~]$ 

Currently using above. Notice new update available will update ASAP.

Comment 29 Tim Kitsos 2012-04-29 22:30:46 UTC
THANKS EVERYONE!  The last available updates (4/28/12 12:01 noon) seems to have fixed the Wifi drop and restart issues. Selinux issue fixed earlier.  THANKS!

Note: Trivial?: I never mentioned that the little wifi icon never seems to show 4 radar bars anymore, just 3 bars. But signal seems ok anyway. I'm only 20ft (& 1 wood stud wall) from wifi box. Print screens from 2011; & 2012: Jan,Feb,Mar all show 4 bars. Sometime during Apr 2012 with above issues bars dropped to 3 bars.

[tim@localhost ~]$ rpm -qa | grep NetworkManager
NetworkManager-gnome-0.9.4-3.git20120403.fc16.i686
NetworkManager-0.9.4-3.git20120403.fc16.i686
NetworkManager-vpnc-0.9.0-1.fc16.i686
NetworkManager-gtk-0.9.4-3.git20120403.fc16.i686
evolution-NetworkManager-3.2.3-3.fc16.i686
NetworkManager-openconnect-0.9.0-3.fc16.i686
NetworkManager-pptp-0.9.0-1.fc16.i686
NetworkManager-glib-0.9.4-3.git20120403.fc16.i686
NetworkManager-openvpn-0.9.0-1.fc16.i686
[tim@localhost ~]$

Comment 30 Jirka Klimes 2012-05-02 06:35:37 UTC
The issue seems to be the same as bug 785772 (IPv6 issues) that is fixed in NetworkManager-0.9.4-3.git20120403.fc16

*** This bug has been marked as a duplicate of bug 785772 ***


Note You need to log in before you can comment on or make changes to this bug.