Bug 807961 - Displaying custom File Not Found page (404) for http://localhost:8080/portal/private/available-portal/not-available-page
Displaying custom File Not Found page (404) for http://localhost:8080/portal/...
Status: ASSIGNED
Product: JBoss Enterprise Portal Platform 5
Classification: JBoss
Component: Portal (Show other bugs)
5.2.0.GA
All All
unspecified Severity medium
: ---
: 5.2.x
Assigned To: Peter Palaga
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-29 05:02 EDT by abhishek vijra
Modified: 2012-06-06 08:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Feature Request
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description abhishek vijra 2012-03-29 05:02:55 EDT
on the EPP 5.X it is required to assign a error page to the url as shown below.

http://localhost:8080/portal/private/available-portal/not-available-page

the key issue is when a page is accessed which is actually not present under the available-portal for example http://localhost:8080/portal/private/classic/somepage.html (somepage.html actually doesn't exists) the portal doesn't show 404 rather it returns to the home page http://localhost:8080/portal/private/classic.

Since on 5.1.1 this was not possible, I tried on EPP 5.2
I tried configuring the error page according to https://community.jboss.org/wiki/CustomErrorPages but I was only successful the /portal level
but not in /portal/classic.

I tried modifying controller.xml <route path="/error.html"> to <route path="/classic/error.html"> but this did not help too.
I guess above mentioned approach only works when there is 404 response but in case of /classic/somepage.html 404 is not received.

I tried analysing  http://anonsvn.jboss.org/repos/gatein/epp/portal/tags/EPP_5_2_0_GA/component/web/controller/src/main/java/org/exoplatform/web/WebAppController.java but no avail.

Note You need to log in before you can comment on or make changes to this bug.