This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 807991 - Unexpected package definition: -readahead
Unexpected package definition: -readahead
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: lab controller (Show other bugs)
0.8
Unspecified Unspecified
unspecified Severity urgent (vote)
: 0.12
: ---
Assigned To: Qixiang Wan
Dan Callaghan
Kickstart
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-29 05:59 EDT by Marian Ganisin
Modified: 2013-04-11 00:55 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-11 00:55:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marian Ganisin 2012-03-29 05:59:40 EDT
Description of problem:

I scheduled a job for recent RHEL 6 and I have found following snippet in kickstart:


%packages --ignoremissing 
# readahead conflicts with auditd, see bug 561486 for detailed explanation.
-readahead


Bug 561486 seems to be solved for some time and this line isn't necessary anymore. Please remove.
Comment 1 Marian Csontos 2012-04-26 03:24:04 EDT
See the release notes of the bug 561486 - it is solved exactly by disabling readahead.
Comment 2 Marian Ganisin 2012-04-26 03:32:30 EDT
We have to test installation of custom package sets, therefore we need full control over packages section. I have no problem with such hacks in common beaker tasks.

However if there is custom kickstart with %packages section defined it has to stay unaltered, otherwise we can't use beaker for this kind of testing.
Comment 3 Marian Ganisin 2012-04-26 03:35:27 EDT
Additionally there doesn't seem to be any reason to modify RHEL5 kickstart based on RHEL6 bug as it happened here for example:

https://beaker.engineering.redhat.com/jobs/223209
Comment 4 Nick Coghlan 2012-10-17 00:32:10 EDT
Bulk reassignment of issues as Bill has moved to another team.
Comment 5 Dan Callaghan 2012-10-24 23:46:12 EDT
We could change our workaround to be to just turn off readhead, as described in bug 561486, instead of removing it. And I agree the workaround should only apply in RHEL6.
Comment 6 Qixiang Wan 2013-02-21 00:43:14 EST
on gerrit: http://gerrit.beaker-project.org/#/c/1744/
Comment 8 Dan Callaghan 2013-04-01 20:50:57 EDT
Verified that -readahead is absent from %packages, and that the sysconfig snippet appears only on RHEL6, and that nothing bad seems to have happened.
Comment 9 Dan Callaghan 2013-04-11 00:55:47 EDT
Beaker 0.12 has been released.

Note You need to log in before you can comment on or make changes to this bug.