Bug 808003 - [glusterfs-3.3.0qa32]: lot of dict NULL errors in the log file
[glusterfs-3.3.0qa32]: lot of dict NULL errors in the log file
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: core (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Raghavendra Bhat
:
Depends On:
Blocks: 817967
  Show dependency treegraph
 
Reported: 2012-03-29 06:20 EDT by Raghavendra Bhat
Modified: 2013-07-24 14:01 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 14:01:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions: glusterfs-3.3.0qa40
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raghavendra Bhat 2012-03-29 06:20:06 EDT
Description of problem:
There are lot of dict NULL errors on the log files since we are refing the NULL dict, which is leading to log file size grow to GBs.


[2012-03-28 04:07:30.186408] W [dict.c:458:dict_ref] (-->/usr/local/lib/libglusterfs.so.0(+0x42037) [0x7f0a4fb12037] (-->/usr/local/lib/glusterfs/3.3.0qa32/xlator/performance/io-threads.so(iot_ftruncate_wrapper+0x23b) [0x7f0a4afc3ca7] (-->/usr/local/lib/glusterfs/3.3.0qa32/xlator/features/locks.so(pl_ftruncate+0xe1) [0x7f0a4b1da43a]))) 0-dict: dict is NULL
[2012-03-28 04:07:30.199566] W [dict.c:458:dict_ref] (-->/usr/local/lib/libglusterfs.so.0(+0x42037) [0x7f0a4fb12037] (-->/usr/local/lib/glusterfs/3.3.0qa32/xlator/performance/io-threads.so(iot_ftruncate_wrapper+0x23b) [0x7f0a4afc3ca7] (-->/usr/local/lib/glusterfs/3.3.0qa32/xlator/features/locks.so(pl_ftruncate+0xe1) [0x7f0a4b1da43a]))) 0-dict: dict is NULL
[2012-03-28 04:07:30.210135] W [dict.c:458:dict_ref] (-->/usr/local/lib/libglusterfs.so.0(+0x42037) [0x7f0a4fb12037] (-->/usr/local/lib/glusterfs/3.3.0qa32/xlator/performance/io-threads.so(iot_ftruncate_wrapper+0x23b) [0x7f0a4afc3ca7] (-->/usr/local/lib/glusterfs/3.3.0qa32/xlator/features/locks.so(pl_ftruncate+0xe1) [0x7f0a4b1da43a]))) 0-dict: dict is NULL
[2012-03-28 04:07:30.222245] W [dict.c:458:dict_ref] (-->/usr/local/lib/libglusterfs.so.0(+0x42037) [0x7f0a4fb12037] (-->/usr/local/lib/glusterfs/3.3.0qa32/xlator/performance/io-threads.so(iot_ftruncate_wrapper+0x23b) [0x7f0a4afc3ca7] (-->/usr/local/lib/glusterfs/3.3.0qa32/xlator/features/locks.so(pl_ftruncate+0xe1) [0x7f0a4b1da43a]))) 0-dict: dict is NULL
[2012-03-28 04:07:30.246198] W [dict.c:458:dict_ref] (-->/usr/local/lib/libglusterfs.so.0(+0x42037) [0x7f0a4fb12037] (-->/usr/local/lib/glusterfs/3.3.0qa32/xlator/performance/io-threads.so(iot_ftruncate_wrapper+0x23b) [0x7f0a4afc3ca7] (-->/usr/local/lib/glusterfs/3.3.0qa32/xlator/features/locks.so(pl_ftruncate+0xe1) [0x7f0a4b1da43a]))) 0-dict: dict is NULL
[2012-03-28 04:07:30.258321] W [dict.c:458:dict_ref] (-->/usr/local/lib/libglusterfs.so.0(+0x42037) [0x7f0a4fb12037] (-->/usr/local/lib/glusterfs/3.3.0qa32/xlator/performance/io-threads.so(iot_ftruncate_wrapper+0x23b) [0x7f0a4afc3ca7] (-->/usr/local/lib/glusterfs/3.3.0qa32/xlator/features/locks.so(pl_ftruncate+0xe1) [0x7f0a4b1da43a]))) 0-dict: dict is NULL
[2012-03-28 04:07:30.270615] W [dict.c:458:dict_ref] (-->/usr/local/lib/libglusterfs.so.0(+0x42037) [0x7f0a4fb12037] (-->/usr/local/lib/glusterfs/3.3.0qa32/xlator/performance/io-threads.so(iot_ftruncate_wrapper+0x23b) [0x7f0a4afc3ca7] (-->/usr/local/lib/glusterfs/3.3.0qa32/xlator/features/locks.so(pl_ftruncate+0xe1) [0x7f0a4b1da43a]))) 0-dict: dict is NULL
[2012-03-28 04:07:30.283344] W [dict.c:458:dict_ref] (-->/usr/local/lib/libglusterfs.so.0(+0x42037) [0x7f0a4fb12037] (-->/usr/local/lib/glusterfs/3.3.0qa32/xlator/performance/io-threads.so(iot_ftruncate_wrapper+0x23b) [0x7f0a4afc3ca7] (-->/usr/local/lib/glusterfs/3.3.0qa32/xlator/features/locks.so(pl_ftruncate+0xe1) [0x7f0a4b1da43a]))) 0-dict: dict is NULL
[2012-03-28 04:07:30.296604] W [dict.c:458:dict_ref] (-->/usr/local/lib/libglusterfs.so.0(+0x42037) [0x7f0a4fb12037] (-->/usr/local/lib/glusterfs/3.3.0qa32/xlator/performance/io-threads.so(iot_ftruncate_wrapper+0x23b) [0x7f0a4afc3ca7] (-->/usr/local/lib/glusterfs/3.3.0qa32/xlator/features/locks.so(pl_ftruncate+0xe1) [0x7f0a4b1da43a]))) 0-dict: dict is NULL
[2012-03-28 04:07:30.323770] W [dict.c:458:dict_ref] (-->/usr/local/lib/libglusterfs.so.0(+0x42037) [0x7f0a4fb12037] (-->/usr/local/lib/glusterfs/3.3.0qa32/xlator/performance/io-threads.so(iot_ftruncate_wrapper+0x23b) [0x7f0a4afc3ca7] (-->/usr/local/lib/glusterfs/3.3.0qa32/xlator/features/locks.so(pl_ftruncate+0xe1) [0x7f0a4b1da43a]))) 0-dict: dict is NULL
[2012-03-28 04:07:30.335594] W [dict.c:458:dict_ref] (-->/usr/local/lib/libglusterfs.so.0(+0x42037) [0x7f0a4fb12037] (-->/usr/local/lib/glusterfs/3.3.0qa32/xlator/performance/io-threads.so(iot_ftruncate_wrapper+0x23b) [0x7f0a4afc3ca7] (-->/usr/local/lib/glusterfs/3.3.0qa32/xlator/features/locks.so(pl_ftruncate+0xe1) [0x7f0a4b1da43a]))) 0-dict: dict is NULL
[2012-03-28 04:07:30.358429] W [dict.c:458:dict_ref] (-->/usr/local/lib/libglusterfs.so.0(+0x42037) [0x7f0a4fb12037] (-->/usr/local/lib/glusterfs/3.3.0qa32/xlator/performance/io-threads.so(iot_ftruncate_wrapper+0x23b) [0x7f0a4afc3ca7] (-->/usr/local/lib/glusterfs/3.3.0qa32/xlator/features/locks.so(pl_ftruncate+0xe1) [0x7f0a4b1da43a]))) 0-dict: dict is NULL
[2012-03-28 04:07:30.371056] W [dict.c:458:dict_ref] (-->/usr/local/lib/libglusterfs.so.0(+0x42037) [0x7f0a4fb12037] (-->/usr/local/lib/glusterfs/3.3.0qa32/xlator/performance/io-threads.so(iot_ftruncate_wrapper+0x23b) [0x7f0a4afc3ca7] (-->/usr/local/lib/glusterfs/3.3.0qa32/xlator/features/locks.so(pl_ftruncate+0xe1) [0x7f0a4b1da43a]))) 0-dict: dict is NULL
[2012-03-28 04:07:30.384243] W [dict.c:458:dict_ref] (-->/usr/local/lib/libglusterfs.so.0(+0x42037) [0x7f0a4fb12037] (-->/usr/local/lib/glusterfs/3.3.0qa32/xlator/performance/io-threads.so(iot_ftruncate_wrapper+0x23b) [0x7f0a4afc3ca7] (-->/usr/local/lib/glusterfs/3.3.0qa32/xlator/features/locks.so(pl_ftruncate+0xe1) [0x7f0a4b1da43a]))) 0-dict: dict is NULL
[2012-03-28 04:07:30.396881] W [dict.c:458:dict_ref] (-->/usr/local/lib/libglusterfs.so.0(+0x42037) [0x7f0a4fb12037] (-->/usr/local/lib/glusterfs/3.3.0qa32/xlator/performance/io-threads.so(iot_ftruncate_wrapper+0x23b) [0x7f0a4afc3ca7] (-->/usr/local/lib/glusterfs/3.3.0qa32/xlator/fea


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Anand Avati 2012-03-29 10:47:17 EDT
CHANGE: http://review.gluster.com/3036 (features/locks: check whether dict is NULL before refing it) merged in master by Vijay Bellur (vijay@gluster.com)
Comment 2 Anand Avati 2012-04-03 07:20:57 EDT
CHANGE: http://review.gluster.com/3073 (locks, stripe: check if dict is NULL before refing it) merged in master by Vijay Bellur (vijay@gluster.com)
Comment 3 Raghavendra Bhat 2012-05-09 05:52:43 EDT
Since we check the dict for NULL before refing it such log messages are not seen. Checked with glusterfs-3.3.0qa40.

Note You need to log in before you can comment on or make changes to this bug.