Bug 808060 - [RFE] virt-who command line option improvements
[RFE] virt-who command line option improvements
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-who (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Radek Novacek
Entitlement Bugs
: FutureFeature, Rebase
Depends On:
Blocks: 771481 836170
  Show dependency treegraph
 
Reported: 2012-03-29 09:11 EDT by Bryan Kearney
Modified: 2013-02-21 04:50 EST (History)
3 users (show)

See Also:
Fixed In Version: virt-who-0.8-1.el6
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
: 808061 (view as bug list)
Environment:
Last Closed: 2013-02-21 04:50:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bryan Kearney 2012-03-29 09:11:37 EDT
Based on some usability discussions, we should enhance the cli command line options as follows.

1) virt-who 
Start in foreground, print errors to stderr (-d for debugging output)

2) virt-who -o
One-shot mode, exit after sending list of guests

3) virt-who -b
4) service virt-who start
Both the same: start on background (do double-fork), log to /var/log, no 
stdout/stderr
Comment 1 Radek Novacek 2012-09-26 02:23:27 EDT
virt-who needs to be rebased to latest version.
Comment 2 Radek Novacek 2012-09-26 03:36:27 EDT
This feature is present in virt-who-0.8-1.el6.
Comment 4 Hui Wang 2013-01-16 21:44:22 EST
Verified the issue, the result is PASS.
Version:
virt-who-0.8-5.el6.noarch

The command line options as following work well according the man config file.
virt-who -o -d
virt-who -b -d
virt-who -i $n -d

So change the status to verified.
Comment 6 errata-xmlrpc 2013-02-21 04:50:38 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0374.html

Note You need to log in before you can comment on or make changes to this bug.