Bug 808062 - firstboot: GUI theme settings not applied after installation from KDE Live
firstboot: GUI theme settings not applied after installation from KDE Live
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: spin-kickstarts (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeroen van Meeuwen
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F17Blocker/F17FinalBlocker
  Show dependency treegraph
 
Reported: 2012-03-29 09:15 EDT by Martin Krizek
Modified: 2012-05-16 15:35 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-16 15:35:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screenshot (123.33 KB, image/png)
2012-03-29 09:15 EDT, Martin Krizek
no flags Details

  None (edit)
Description Martin Krizek 2012-03-29 09:15:22 EDT
Created attachment 573671 [details]
screenshot

Description of problem:
After installing F17 beta RC2 KDE live, oxygen-gtk theme is not applied, instead, the default one is applied.

Version-Release number of selected component (if applicable):
Fedora 17 beta RC2 KDE Live
firstboot-17.0-1.fc17.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install Fedora 17 beta RC2 from KDE Live
2. Boot into firstboot
3.
  
Actual results:
GUI theme (oxygen-gtk I guess) is not applied, the default, 'ugly', one appears (see screenshot)

Expected results:
GUI theme is applied

Additional info:
Does not happen when installing from DVD with only KDE selected.
Comment 1 Martin Krizek 2012-03-29 09:22:10 EDT
Info: oxygen-gtk is installed
Comment 2 Rex Dieter 2012-05-14 16:39:24 EDT
Let's go with simplest fix then, if we can't get something better, reverting to manually setting oxygen-gtk as gtk theme for root on kde spin:

https://fedorahosted.org/spin-kickstarts/changeset/3bcca4d1c47d8ec22e3e2e4dbaab326eee9b7bc6/fedora-live-kde-base.ks

and followup (adding reference to this bug):
https://fedorahosted.org/spin-kickstarts/changeset/3bcca4d1c47d8ec22e3e2e4dbaab326eee9b7bc6/fedora-live-kde-base.ks


hopefully we can get this in f17 GA.
Comment 3 Rex Dieter 2012-05-14 16:43:43 EDT
nominating blocker per 
http://fedoraproject.org/wiki/Fedora_17_Final_Release_Criteria#Final_Release_Requirements 

item 19:  The proposed final Fedora artwork must be included and enabled by default for the installer, graphical boot, firstboot, graphical login and desktop background.


since the result of not including this fix is an ugly/unthemed firstboot on kde spin
Comment 4 Rex Dieter 2012-05-14 16:48:39 EDT
OK, got confirmation from dgilmore that spin composes use git, so getting this pkg updated is not necessarily a blocker (but still would be nice).
Comment 5 Bruno Wolff III 2012-05-14 17:14:46 EDT
The kickstart files really shouldn't be changed during freezes unless they are addressing a that bug gets at least a NTH rating, so it still should get raised as a potential blocker.
Comment 6 Adam Williamson 2012-05-14 17:45:11 EDT
the intent of that criterion was the 'artwork' delivered by the design team, but I guess there's a strong case for considering this an infringement of it. I'm +1 NTH at least, anyway.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Kamil Páral 2012-05-15 08:25:02 EDT
This influences only firstboot, right? If that's the case, I'm +1 NTH, -1 blocker. But if it influences also other GTK applications run inside KDE session, then I'd consider +1 blocker.
Comment 8 Rex Dieter 2012-05-15 08:37:48 EDT
in practical terms, yes, this only affects (and helps) firstboot, since it is launched prior to any user session that has an xsettings daemon.

Normal user sessions (including root) should already 'just work'.
Comment 9 Adam Williamson 2012-05-16 01:53:27 EDT
this should be fixed in TC6, as the spin-kickstarts change landed. Setting ON_QA.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 10 Kamil Páral 2012-05-16 05:17:31 EDT
This is fixed with TC6 KDE Live i686.
Comment 11 Jaroslav Reznik 2012-05-16 09:20:56 EDT
Confirmed.
Comment 12 Kamil Páral 2012-05-16 15:35:23 EDT
Two people confirmed, closing bug.

Note You need to log in before you can comment on or make changes to this bug.