Bug 808064 - SSSD memory usage continuously growing
Summary: SSSD memory usage continuously growing
Keywords:
Status: CLOSED DUPLICATE of bug 807363
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sssd
Version: 6.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Stephen Gallagher
QA Contact: IDM QE LIST
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-03-29 13:24 UTC by Dmitri Pal
Modified: 2020-05-02 16:48 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-04-09 11:33:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github SSSD sssd issues 2293 0 None None None 2020-05-02 16:48:19 UTC

Description Dmitri Pal 2012-03-29 13:24:50 UTC
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/sssd/ticket/1251

Dear SSSD team,

we are experiencing an issue with SSSD, where `sssd_be` is consuming a lot of memory. The RAM consumption grows continuously in a certain setup where a SFTP/SSH login happens every 30 seconds.

During a time period of 17 hours the memory usage of SSSD increased by 20% respectively 200MB (1024MB system memory).
After restarting SSSD the memory consumption goes back to normal.
\\The attached `debug log file` shows the login sequence of the mentioned SFTP user.

Since we don't have a large LDAP directory (~60 Unix users / ~20 Unix groups) I suppose we might have a misconfiguration in our `sssd.conf` (see attachments).

\\

When I remove the `cache` file of SSSD and run an `id` on 50 LDAP users the memory consumption grows only about ~5MB. The memory usage stays the same even when I run the `id` command over and over again (executed at least 20 times).
The commands `getent passwd` and `getent group` also do not increase the memory usage of SSSD.

\\

Information about the environment/system:
 * LDAP is ID and AUTH provider
 * LDAP schema is rfc2307bis
 * RHEL 6.2 / CentOS 6.2
 * sssd-client-1.5.1-66.el6_2.3.i686
 * sssd-1.5.1-66.el6_2.3.i686

Attachments:
 * sssd.conf (sanitized)
 * sssd_EXAMPLE.log (sanitized)
 * sssd_mem_usage.png (graph)

\\

If you need any further debug information please let me know.\\Many thanks for looking into this issue.

Kind regards,
mayak


Note You need to log in before you can comment on or make changes to this bug.