Bug 808066 - Kalarm not allowing editing or deleting of alarms
Kalarm not allowing editing or deleting of alarms
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kdepim (Show other bugs)
16
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-29 09:25 EDT by Robert Story
Modified: 2012-04-06 17:32 EDT (History)
7 users (show)

See Also:
Fixed In Version: kdepim-4.8.1-4.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-06 17:32:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 295926 None None None Never

  None (edit)
Description Robert Story 2012-03-29 09:25:48 EDT
Description of problem:
Kalarm not allowing editing or deleting of alarms. See upstream bug:
https://bugs.kde.org/show_bug.cgi?id=295926

Version-Release number of selected component (if applicable):
kdepim-4.8.1-3.fc16.x86_64

How reproducible:
every time

Steps to Reproduce:
1. create new alarm, if needed
2. edit any alarm
3.
  
Actual results:
"error saving alarm"

Expected results:
no error

Additional info:
Comment 1 Rex Dieter 2012-03-29 09:39:34 EDT
works ok on my f16 (and f17 testing) boxes, so I can't reproduce this problem.
Comment 2 Rex Dieter 2012-03-29 09:41:20 EDT
wait! spoke too soon, my test audio alarm went off (and is repeatedly playing... another bug?), and *now* it won't let me edit or delete it.
Comment 3 Rex Dieter 2012-03-29 09:43:32 EDT
OK, according to the upstream bug, this has been fixed in kde-4.8.2 (coming soon, early april).
Comment 4 Robert Story 2012-03-29 09:58:33 EDT
updated these rpms from updates-testing:

(1/4): kdelibs-4.8.1-3.fc16.x86_64.rpm
(2/4): kdelibs-common-4.8.1-3.fc16.x86_64.rpm
(3/4): kdepimlibs-4.8.1-3.fc16.x86_64.rpm
(4/4): kdepimlibs-akonadi-4.8.1-3.fc16.x86_64.rpm

then quit kalarms and restarted it.. and it doesn't show any of my alarms! The alarm list is completely empty. :-(

Any chance of getting a fix before then? I depend on several daily alarms... Or is there a revert procedure to got back to the old versions of kdepim (or kde*, if necessary)?
Comment 5 Rex Dieter 2012-03-29 10:05:56 EDT
I guess they did have a reference to the fix,
git commit ae66e32fb194e01e06521c78e9c72d772d291261
I'll see if I can track that down.
Comment 6 Rex Dieter 2012-03-29 10:20:39 EDT
OK, test build underway, 
http://koji.fedoraproject.org/koji/taskinfo?taskID=3943410
Comment 7 Fedora Update System 2012-03-29 11:04:43 EDT
kdepim-4.8.1-4.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kdepim-4.8.1-4.fc16
Comment 8 Fedora Update System 2012-03-29 11:05:13 EDT
kdepim-4.8.1-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kdepim-4.8.1-4.fc17
Comment 9 Robert Story 2012-03-29 11:36:07 EDT
works for me.. though my main user was still coming up with a blank alarm list and all menu item's greyed out.. a new user worked fine.. anyone with the empty list/greyed out menus should see comment 11 of http://old.nabble.com/-Bug-290050--New%3A-cannot-add-alarms-after-upgrading-to-4.8-beta-td33047691.html

Thanks for the quick fix, Rex!
Comment 10 Fedora Update System 2012-03-29 22:56:50 EDT
Package kdepim-4.8.1-4.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kdepim-4.8.1-4.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-4857/kdepim-4.8.1-4.fc17
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2012-04-06 17:32:41 EDT
kdepim-4.8.1-4.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.