Bug 808078 - Setting xdata on writev doesn't work
Setting xdata on writev doesn't work
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: protocol (Show other bugs)
mainline
Unspecified Unspecified
medium Severity high
: ---
: ---
Assigned To: Amar Tumballi
Sachidananda Urs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-29 09:58 EDT by Jeff Darcy
Modified: 2013-12-18 19:07 EST (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:27:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Darcy 2012-03-29 09:58:48 EDT
Xdr_to_generic expects the variable-length xdata to be in the same contiguous memory buffer as the fixed part, but currently only the length is present.  This doesn't affect most calls, because the buffer layout is a side effect of the vector_sizer stuff in the transport layer and most calls don't use that method, but it probably does affect the return side of readv as well.
Comment 1 Jeff Darcy 2012-03-29 09:59:56 EDT
http://review.gluster.com/3038
Comment 2 Amar Tumballi 2012-04-02 00:07:38 EDT
Thanks for the patch Jeff, I will run some tests with/wo your patch and mark it reviewed after that.
Comment 3 Amar Tumballi 2012-05-24 05:59:14 EDT
http://review.gluster.com/3182 is merged in master branch, not planing to backport right away to release-3.3 as there are no consumers yet. Hence moving it to ON_QA for master branch.
Comment 4 Sachidananda Urs 2012-06-01 01:30:13 EDT
Not part of 3.3.0 release will be testing later. Changes are in master.
Comment 5 Sachidananda Urs 2012-12-26 02:33:20 EST
This isn't fixed in qa5, will retry again on qa6.

Note You need to log in before you can comment on or make changes to this bug.