This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 808082 - Monitoring and Config not working with SELinux enabled
Monitoring and Config not working with SELinux enabled
Status: CLOSED NEXTRELEASE
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
1.7
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Lestach
Red Hat Satellite QA List
:
: 1014909 (view as bug list)
Depends On:
Blocks: space27
  Show dependency treegraph
 
Reported: 2012-03-29 10:14 EDT by schuler.philipp
Modified: 2017-09-28 13:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-14 16:41:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description schuler.philipp 2012-03-29 10:14:21 EDT
Description of problem:
when having selinux enabled service wont start up properly for monitoring and config

Version-Release number of selected component (if applicable):
1.7 postgres backend , Centos 6


Steps to Reproduce:
1. setenforce 1
2. spacewalk-selinux-enable
3. spacewalk-service-start
  
Actual results:
2012-03-29 16:08:38 InstallSoftwareConfig: 	!! DBI connect('dbname=spaceschema','spaceuser',...) failed: could not connect to server: Permission denied
	Is the server running locally and accepting
	connections on Unix domain socket "/tmp/.s.PGSQL.5432"? at /usr/share/perl5/vendor_perl/RHN/DBI.pm line 72

	Starting InstallSoftwareConfig ...  [ FAIL ]
2012-03-29 16:08:38 InstallSoftwareConfig: WARNING: STARTED BUT *NOT* RUNNING
2012-03-29 16:08:38 InstallSoftwareConfig: ERRORS ENCOUNTERED DURING LAST ACTION:
2012-03-29 16:08:38 InstallSoftwareConfig: 	!! DBI connect('dbname=spaceschema','spaceuser',...) failed: could not connect to server: Permission denied
	Is the server running locally and accepting
	connections on Unix domain socket "/tmp/.s.PGSQL.5432"? at /usr/share/perl5/vendor_perl/RHN/DBI.pm line 72

2012-03-29 16:08:38 Monitoring: 	!! Monitoring configuration load failed
2012-03-29 16:08:38 Monitoring: 	!! Monitoring configuration not loaded - not starting MOC functions!
[ FAIL ]
2012-03-29 16:08:38 Monitoring: WARNING: STARTED BUT *NOT* RUNNING
2012-03-29 16:08:38 Monitoring: ERRORS ENCOUNTERED DURING LAST ACTION:
2012-03-29 16:08:38 Monitoring: 	!! Monitoring configuration load failed
2012-03-29 16:08:38 Monitoring: 	!! Monitoring configuration not loaded - not starting MOC functions!
Starting MonitoringScout ...  
2012-03-29 16:08:38 InstallSoftwareConfig: WARNING: STARTED BUT *NOT* RUNNING
2012-03-29 16:08:38 InstallSoftwareConfig: ERRORS ENCOUNTERED DURING LAST ACTION:
2012-03-29 16:08:38 InstallSoftwareConfig: 	!! DBI connect('dbname=spaceschema','spaceuser',...) failed: could not connect to server: Permission denied
	Is the server running locally and accepting
	connections on Unix domain socket "/tmp/.s.PGSQL.5432"? at /usr/share/perl5/vendor_perl/RHN/DBI.pm line 72

Expected results:
should startup without errors just like with selinux disabled

Additional info:
Comment 1 Michael Mráka 2013-10-07 03:08:35 EDT
*** Bug 1014909 has been marked as a duplicate of this bug. ***
Comment 3 schuler.philipp 2017-03-14 16:41:48 EDT
I'm closing this as it was affecting 1.7, now we are at 2.6, monitoring got dropped anyways
Comment 4 Eric Herget 2017-09-28 13:56:42 EDT
This BZ closed some time during 2.5, 2.6 or 2.7.  Adding to 2.7 tracking bug.

Note You need to log in before you can comment on or make changes to this bug.