Bug 808118 - Monitoring : "df" fails when run as nocpulse user.
Monitoring : "df" fails when run as nocpulse user.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite Proxy 5
Classification: Red Hat
Component: Server (Show other bugs)
550
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Michael Mráka
Martin Korbel
:
Depends On:
Blocks: sat550-proxy sat550-post-ga/sat550-test-blockers
  Show dependency treegraph
 
Reported: 2012-03-29 11:56 EDT by Dimitar Yordanov
Modified: 2012-10-02 06:54 EDT (History)
6 users (show)

See Also:
Fixed In Version: perl-NOCpulse-Probe-1.184.15-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-02 06:54:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dimitar Yordanov 2012-03-29 11:56:52 EDT
Description of problem:
Command "df" fails when in run as nocpulse user.

Version-Release number of selected component (if applicable):
SW 17
RHEL6 (on EL 5 the problem is not presented)

How reproducible:
100%

Steps to Reproduce:
1. SW 1.7 with Enables Monitoring
   Admin -> Spacewalk Configuration -> Enable Monitoring
   Admin -> Spacewalk Configuration -> Monitoring -> Enable Monitoring Scout
   Restart SW

2. Register RHEL6 System to SW 1.7
3. Set Monitoring entitlement to the system
   Systems -> System -> System Properties
4. Create Probe Suite
    Monitoring -> Probe Suites
5. Add the system to the probe suit
    Monitoring -> Probe Suites -> Your Suit -> Systems -> add systems to probe suite
   adn deploy the SSH key -- see documentation.
6. Add "Linux: Disk Usage" Prob to the Probe Suite
     Monitoring -> Probe Suites -> Your Suit -> Probes -> create new probe -> Linux: Disk Usage
7. Configure the probe field "File System". (Ex. /dev/sda1)
8. Push the Scout
    Monitoring -> Scout Config Push -> Spacewalk Monitoring Scout -> Push Scout Configs


  
Actual results:
The probe Fails.
Command failed with status 1: /bin/df: `/root/.gvfs': Permission denied 

Expected results:
No errors.

Additional info:

Login to the El6 system.
# su - nocpulse

-bash-4.1$ df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/mapper/vg_hpdl165g601-lv_root
                      51606140   3506160  45478540   8% /
tmpfs                  4029456       112   4029344   1% /dev/shm
/dev/sda1               495844     58275    411969  13% /boot
/dev/mapper/vg_hpdl165g601-lv_home
                      91596872    188124  86755900   1% /home
df: `/root/.gvfs': Permission denied
Comment 1 Michael Mráka 2012-03-30 02:23:17 EDT
/root/.gvfs is gnome virtual fs mount point. This most likely means you 
run gnome as root on the monitored machine. Anyway it isn't not
monitoring bug but client misconfiguration.

Please logout root's gnome session and retry.
Comment 3 Dimitar Yordanov 2012-03-30 04:12:55 EDT
The problem is presented only if gvfs-fuse-daemon is running.

  /usr/libexec//gvfs-fuse-daemon  /root/.gvfs

From what I see on my EL6 system GNOME root session has no impact.
Comment 4 Miroslav Suchý 2012-04-19 11:02:35 EDT
commited to spacewalk.git as 5927ed33b158e95d3fc98f9d2884c62e50da2935

Note You need to log in before you can comment on or make changes to this bug.