Bug 808121 - cupsd interferes with loop devices (?!)
Summary: cupsd interferes with loop devices (?!)
Keywords:
Status: CLOSED DUPLICATE of bug 808109
Alias: None
Product: Fedora
Classification: Fedora
Component: cups
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-03-29 16:09 UTC by Will Woods
Modified: 2012-04-12 18:54 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-30 08:33:04 UTC


Attachments (Terms of Use)
mount.sh (test script) (677 bytes, text/plain)
2012-03-29 16:09 UTC, Will Woods
no flags Details

Description Will Woods 2012-03-29 16:09:56 UTC
Created attachment 573727 [details]
mount.sh (test script)

No, seriously.

After installing cups-1.5.2-6.fc16.x86_64, umounting a loop-device mount will *not* free the loop device, and any attempt to manually delete the loop device returns EBUSY.

I'm attaching the test script that I used while trying to diagnose this problem. In my tests it fails only when cupsd is running. Killing cupsd will allow the test to succeed.

(This actually took me a long time to diagnose because I had so much trouble believing that cupsd was the culprit - I kept starting my tests over because I assumed that I just missed the *real* problem!)

Comment 1 Will Woods 2012-03-29 16:12:03 UTC
Possibly related: bug 747114

Comment 2 Tim Waugh 2012-03-30 08:32:20 UTC
Please try the procedure detailed in bug #747114 comment #7.

Comment 3 Tim Waugh 2012-03-30 08:33:04 UTC
Also, I'm pretty sure this *is* a duplicate of bug #747114.

*** This bug has been marked as a duplicate of bug 747114 ***

Comment 4 Tim Waugh 2012-04-02 12:13:10 UTC
Actually bug #747114 seems to be a different cause.

*** This bug has been marked as a duplicate of bug 808109 ***


Note You need to log in before you can comment on or make changes to this bug.