Bug 808185 - Multi-monitor config wakeup after sleep shows black screen after a second
Multi-monitor config wakeup after sleep shows black screen after a second
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kde-baseapps (Show other bugs)
16
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-29 14:41 EDT by slartibart70
Modified: 2012-07-17 11:48 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-17 11:48:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description slartibart70 2012-03-29 14:41:23 EDT
Description of problem:
I run fedora16 on a t420 laptop with a second monitor attached to vga(analog) output and a different screen resolution (native: 1600x900, secondary 1280x1024)
Running this configuration and sending the laptop to sleep, then removing the secondary monitor, and then waking it up again shows the typical graphical kde login request. But, after loging in successfully, the t420 internal monitor shows the desktop for just 1 second (approx) and goes blank immediately.
Switching to a second consolse using alt-ctrl-F2 is ok, switching back to alt-F1 shows the desktop again for a second before it goes blank again.
You can repeat this game foerver, the only thing helping is rebooting...

the t420 uses internal intel core i7 chipset graphics, there is no other internal graphics card.

This also fails the other way around, i.e. having the laptop sleep in single monitor config and then attaching a secondary monitor to analog vga and waking it up again. Login is ok, both screens show the desktops contents and go blank after a second or so. (see above)
Here again, rebooting on text-console is my only remedy.


How reproducible:
Nearly everytime since upgrade to kernel 3.2.9/3.3.x and kde4.8
kde 4.7 was ok, kde displayed the screen config dialog on the primary monitor and you could switch the screen config. All was fine then.
Comment 1 Martin Bříza 2012-07-17 11:44:27 EDT
Hello,
I read a few similar reports upstream and it seems this issue could be driver-related. Please, have you updated your graphic card drivers since then and tested the wakeup?
Thank you.
Comment 2 slartibart70 2012-07-17 11:48:14 EDT
Hi,
seems to be solved by now, after (a) upgrading to newer kernels in fc16 and of course, (b) upgrading to fc17.
thanks anyway!

Note You need to log in before you can comment on or make changes to this bug.