Bug 80819 - Kernel is not handling multiple tasks correctly (not sure its a task problem)
Kernel is not handling multiple tasks correctly (not sure its a task problem)
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-31 12:58 EST by Thiago Sayao
Modified: 2008-01-17 12:49 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:40:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thiago Sayao 2002-12-31 12:58:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
When i copy files from a cd-rom for example all the system gets slow
(maybe an ext3 problem ?). I ran the command top (several times) to see the cpu
utilization and the maximum was 20%. I copied the files with both nautilus and
the command cp and both gives me the same result, everything gets slow. By slow
i mean *very* slow.

My hardware:
 Athlon 1.2Ghz 256mb ram
 52x creative cd-rom
 Hd maxtor 40gb ata 133 (my board is ATA 100)
 Asus A7A133.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Copy files from a not-so-fast media to the root partition.
2. The system will be ***VERY*** slow during the copy.

    

Additional info:
Comment 1 Nathan G. Grennan 2002-12-31 14:52:20 EST
Check to see if your cdrom is using DMA with hdparm -d device  RedHat has made
it policy to disable DMA on cdrom drives for compatiability reasons. Which has
the effect of greatly slowing it down for everyone else.
Comment 2 Thiago Sayao 2002-12-31 17:53:20 EST
[root@zeus sayao]# /sbin/hdparm -d /dev/cdrom
 
/dev/cdrom:
 using_dma    =  1 (on)


Its enabled. 
Comment 3 Thiago Sayao 2003-01-04 19:34:34 EST
During the boot kernel shows this message:
/dev/hda
DMA Disabled

my cd-rom is /dev/hda

Comment 4 Jim Shanks 2003-03-04 13:13:22 EST
The only way that I have found to reliably switch CD-ROM drives to DMA Mode is to:

su to root
cd /etc/sysconfig
cp harddisks harddiskhda (or harddiskhdb or whatever your CD-ROM is.)

edit the newly created harddiskhda with a text editor and change the USE_DMA=0
to USE_DMA=1.

save the file and restart the machine.
Comment 5 Bugzilla owner 2004-09-30 11:40:21 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.