Bug 8082 - fdisk refuse to add a new partition
fdisk refuse to add a new partition
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: util-linux (Show other bugs)
6.1
sparc Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-12-31 07:45 EST by franck.lemonnier
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-17 18:31:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description franck.lemonnier 1999-12-31 07:45:34 EST
Hi,

during my Sparc Redhat 6.1 install, I do not assign the whole disk space. I
keep 1 Gb for later.

So, recently I need to allocate this disk space. So, I use fdisk to declare
a new partition but it complains about a 'device or ressource busy" ???

So, the operations I try to do :

[root@ors40428 ~]# fdisk /dev/hda

Command (m for help): p

Disk /dev/hda (Sun disk label): 15 heads, 63 sectors, 8892 cylinders
Units = cylinders of 945 * 512 bytes

   Device Flag    Start       End    Blocks   Id  System
/dev/hda1             0      4335   2048256   83  Linux native
/dev/hda2  u       4335      5202    409657+  83  Linux native
/dev/hda3             0      8892   4201470    5  Whole disk
/dev/hda4          5202      5757    262237+  82  Linux swap
/dev/hda5          5757      5974    102532+  83  Linux native

Command (m for help): n
Partition number (1-8): 6
First cylinder (4335-8892): 5974
Last cylinder or +size or +sizeM or +sizeK (5974-8892, default 8892): 8892

Command (m for help): p

Disk /dev/hda (Sun disk label): 15 heads, 63 sectors, 8892 cylinders
Units = cylinders of 945 * 512 bytes

   Device Flag    Start       End    Blocks   Id  System
/dev/hda1             0      4335   2048256   83  Linux native
/dev/hda2  u       4335      5202    409657+  83  Linux native
/dev/hda3             0      8892   4201470    5  Whole disk
/dev/hda4          5202      5757    262237+  82  Linux swap
/dev/hda5          5757      5974    102532+  83  Linux native
/dev/hda6          5974      8892   1378282+  83  Linux native

Command (m for help): w
The partition table has been altered!

Calling ioctl() to re-read partition table.
Syncing disks.
Re-read table failed with error 16: Device or resource busy.
Reboot your system to ensure the partition table is updated.

What's the matter whith fdisk ?

NB: The workstation is an Ultra 5. I try using fdisk in single user mode
but the same problem happens.
Comment 1 Cristian Gafton 2000-02-17 18:31:59 EST
You have other partitions from that hard disk already mounted or in use by your
system, so the kernel partition table for the disc can not be updated. The data
has been written to disk, but you need to reboot for changes to take effect. Or
alternatively, umount everything before modifying the partition table.
Comment 2 Cristian Gafton 2000-02-17 18:41:59 EST
*** Bug 6817 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.