Bug 808203 - NM only accepts first RDNSS from router advertisements and disconnects because of RDNSS timeout
NM only accepts first RDNSS from router advertisements and disconnects becaus...
Status: CLOSED DUPLICATE of bug 785772
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
17
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-29 15:38 EDT by Pavel Šimerda (pavlix)
Modified: 2012-04-19 17:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-19 17:12:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Šimerda (pavlix) 2012-03-29 15:38:17 EDT
After update to NetworkManager-0.9.4.0-1.git20120328.fc17.x86_64, NM drops connection on every RDNSS timeout. Logs that previously contained records about
refreshed RDNSS records disappeared. This regression can possibly make NM unusable on networks that use RA with RDNSS records for IPv6 configuration.

# cat /etc/NetworkManager/NetworkManager.conf 
[main]
plugins=ifcfg-rh
[logging]
level=DEBUG
domains=IP4,IP6,DHCP4,DHCP6,WIFI,HW,BT,SUPPLICANT,SUSPEND,CORE,DEVICE

# grep debug /etc/rsyslog.conf 
*.*						/tmp/debug

# grep -i rdnss /tmp/debug
Mar 29 21:18:56 dragon NetworkManager[6160]: <debug> [1333048736.186648] [nm-ip6-manager.c:277] rdnss_expired(): (wlan0): IPv6 RDNSS information expired
Mar 29 21:18:56 dragon NetworkManager[6160]: <debug> [1333048736.186712] [nm-ip6-manager.c:312] set_rdnss_timeout(): (wlan0): removing expired RA-provided nameserver fe80::20c:42ff:fe13:857b
Mar 29 21:19:07 dragon NetworkManager[6160]: <debug> [1333048747.133161] [nm-ip6-manager.c:748] process_nduseropt_rdnss(): (wlan0): found RA-provided nameserver fe80::20c:42ff:fe13:857b (expires in 610 seconds)
Mar 29 21:29:17 dragon NetworkManager[6160]: <debug> [1333049357.186226] [nm-ip6-manager.c:277] rdnss_expired(): (wlan0): IPv6 RDNSS information expired
Mar 29 21:29:17 dragon NetworkManager[6160]: <debug> [1333049357.186317] [nm-ip6-manager.c:312] set_rdnss_timeout(): (wlan0): removing expired RA-provided nameserver fe80::20c:42ff:fe13:857b
Mar 29 21:29:28 dragon NetworkManager[6160]: <debug> [1333049368.554401] [nm-ip6-manager.c:748] process_nduseropt_rdnss(): (wlan0): found RA-provided nameserver fe80::20c:42ff:fe13:857b (expires in 610 seconds)

Related to bug 753482 but much worse.
Comment 1 Pavel Šimerda (pavlix) 2012-03-30 01:56:34 EDT
I forgot to add that this was experienced only on wireless so far.
Comment 2 Łukasz Jernaś 2012-04-03 12:19:12 EDT
Happens also on F16 even with wired connetions with IPv6 enabled
Comment 3 Pavel Šimerda (pavlix) 2012-04-03 12:29:50 EDT
Hmm, now I actually have some positive messages:

Apr  3 08:22:39 dragon NetworkManager[697]: <debug> [1333434159.114071] [nm-ip6-manager.c:730] process_nduseropt_rdnss(): (eth0): refreshing RA-provided nameserver fe80::20c:42ff:fe13:857b (expires in 1810 seconds)

Still NetworkManager-0.9.4.0-1.git20120328.fc17.x86_64, kernel-3.3.0-1.fc17.x86_64

I don't know what makes the difference.
Comment 4 Dan Winship 2012-04-19 10:37:42 EDT

*** This bug has been marked as a duplicate of bug 785772 ***
Comment 5 Pavel Šimerda (pavlix) 2012-04-19 16:39:46 EDT
I believe this bugreport was closed duplicate by mistake. I don't see any
relation between this bug and bug 785772.
Comment 6 Dan Winship 2012-04-19 17:12:51 EDT
Yeah, sorry, I should have explained. NM's behavior in 785772 causes the kernel to discard every RA after the first one, so NM never sees another RDNSS notification after that and so is guaranteed to hit the timeout.

*** This bug has been marked as a duplicate of bug 785772 ***
Comment 7 Pavel Šimerda (pavlix) 2012-04-19 17:14:23 EDT
Ok then, but please don't close the other one.

Note You need to log in before you can comment on or make changes to this bug.