Bug 808234 - [abrt] openbox-3.5.0-3.fc16: Menu.py:95:__eq__:UnicodeEncodeError: 'ascii' codec can't encode characters in position 5-13: ordinal not in range(128)
[abrt] openbox-3.5.0-3.fc16: Menu.py:95:__eq__:UnicodeEncodeError: 'ascii' co...
Status: CLOSED DUPLICATE of bug 799663
Product: Fedora
Classification: Fedora
Component: openbox (Show other bugs)
16
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
abrt_hash:8b556a328d3cf81e94b5b3b2bb9...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-29 17:51 EDT by Dmitri Skok
Modified: 2012-03-30 08:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-30 08:51:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: smolt_data (2.18 KB, text/plain)
2012-03-29 17:51 EDT, Dmitri Skok
no flags Details

  None (edit)
Description Dmitri Skok 2012-03-29 17:51:53 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        /usr/bin/python /usr/libexec/openbox-xdg-menu applications
executable:     /usr/libexec/openbox-xdg-menu
kernel:         3.2.2-1.fc16.i686.PAE
reason:         Menu.py:95:__eq__:UnicodeEncodeError: 'ascii' codec can't encode characters in position 5-13: ordinal not in range(128)
time:           Пн. 30 янв. 2012 01:33:49
uid:            500
username:       dvs

smolt_data:     Binary file, 2232 bytes

backtrace:
:Menu.py:95:__eq__:UnicodeEncodeError: 'ascii' codec can't encode characters in position 5-13: ordinal not in range(128)
:
:Traceback (most recent call last):
:  File "/usr/libexec/openbox-xdg-menu", line 94, in <module>
:    menu = xdg.Menu.parse(menufile)
:  File "/usr/lib/python2.7/site-packages/xdg/Menu.py", line 524, in parse
:    __parse(doc, filename, tmp["Root"])
:  File "/usr/lib/python2.7/site-packages/xdg/Menu.py", line 545, in __parse
:    __parseMenu(child, filename, parent)
:  File "/usr/lib/python2.7/site-packages/xdg/Menu.py", line 699, in __parseMenu
:    __parse(child, filename, m)
:  File "/usr/lib/python2.7/site-packages/xdg/Menu.py", line 585, in __parse
:    __parseMergeFile(child.childNodes[0].nodeValue, child, filename, parent)
:  File "/usr/lib/python2.7/site-packages/xdg/Menu.py", line 755, in __parseMergeFile
:    __mergeFile(value, child, parent)
:  File "/usr/lib/python2.7/site-packages/xdg/Menu.py", line 799, in __mergeFile
:    __parse(child,filename,parent)
:  File "/usr/lib/python2.7/site-packages/xdg/Menu.py", line 594, in __parse
:    __parseDefaultMergeDirs(child, filename, parent)
:  File "/usr/lib/python2.7/site-packages/xdg/Menu.py", line 770, in __parseDefaultMergeDirs
:    __parseMergeDir(os.path.join(dir, "menus", basename + "-merged"), child, filename, parent)
:  File "/usr/lib/python2.7/site-packages/xdg/Menu.py", line 763, in __parseMergeDir
:    __mergeFile(os.path.join(value, item), child, parent)
:  File "/usr/lib/python2.7/site-packages/xdg/Menu.py", line 799, in __mergeFile
:    __parse(child,filename,parent)
:  File "/usr/lib/python2.7/site-packages/xdg/Menu.py", line 545, in __parse
:    __parseMenu(child, filename, parent)
:  File "/usr/lib/python2.7/site-packages/xdg/Menu.py", line 701, in __parseMenu
:    parent.addSubmenu(m)
:  File "/usr/lib/python2.7/site-packages/xdg/Menu.py", line 177, in addSubmenu
:    submenu += newmenu
:  File "/usr/lib/python2.7/site-packages/xdg/Menu.py", line 86, in __add__
:    self.addSubmenu(submenu)
:  File "/usr/lib/python2.7/site-packages/xdg/Menu.py", line 176, in addSubmenu
:    if submenu == newmenu:
:  File "/usr/lib/python2.7/site-packages/xdg/Menu.py", line 95, in __eq__
:    if self.Name == str(other):
:UnicodeEncodeError: 'ascii' codec can't encode characters in position 5-13: ordinal not in range(128)
:
:Local variables in innermost frame:
:self: <xdg.Menu.Menu instance at 0x985426c>
:other: <xdg.Menu.Menu instance at 0x9854ecc>
Comment 1 Dmitri Skok 2012-03-29 17:51:56 EDT
Created attachment 573809 [details]
File: smolt_data
Comment 2 Miroslav Lichvar 2012-03-30 08:51:41 EDT

*** This bug has been marked as a duplicate of bug 799663 ***

Note You need to log in before you can comment on or make changes to this bug.