Bug 808285 - gcc releases up to 4.6.2 triggers ICE when compiling Gambit Scheme at -O2 on ppc64
gcc releases up to 4.6.2 triggers ICE when compiling Gambit Scheme at -O2 on ...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gcc (Show other bugs)
6.4
ppc64 Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Jakub Jelinek
qe-baseos-tools
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-29 23:34 EDT by Michel Alexandre Salim
Modified: 2014-09-30 12:35 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-30 12:35:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Build log on fedora-16-ppc64 (58.25 KB, text/x-log)
2012-03-29 23:34 EDT, Michel Alexandre Salim
no flags Details
Preprocessed source that triggered the internal compiler error (959.50 KB, application/octet-stream)
2012-03-29 23:36 EDT, Michel Alexandre Salim
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNU Compiler Collection 52829 None None None Never

  None (edit)
Description Michel Alexandre Salim 2012-03-29 23:34:44 EDT
Created attachment 573869 [details]
Build log on fedora-16-ppc64

Description of problem:
gambit-c up to version 4.6.3 builds cleanly on ppc64, but this is no longer the case with the latest two releases

Version-Release number of selected component (if applicable):
gambit-c-4.6.5-1.el6

How reproducible:
Always

Steps to Reproduce:
1. fedpkg clone gambit-c && cd gambit-c
2. fedpkg switch-branch el6 && fedpkg srpm
3. rpm -i gambit-c-*.src.rpm
4. rpmbuild -bb --with ppc64 gambit-c.spec
  
Actual results:
See attached log for 4.6.5 (on Fedora 16; the EPEL 6 target in mock is currently broken)

Expected results:
Build succeeds

Additional info:
Comment 1 Michel Alexandre Salim 2012-03-29 23:36:58 EDT
Created attachment 573870 [details]
Preprocessed source that triggered the internal compiler error
Comment 2 Michel Alexandre Salim 2012-03-30 01:57:03 EDT
Reported upstream:

  http://www.iro.umontreal.ca/~gambit/bugzilla/show_bug.cgi?id=155
Comment 3 Michel Alexandre Salim 2012-04-02 00:16:31 EDT
This bug is fixed in GCC 4.7.0 (as tested on the PPC test machine's fedora-rawhide-ppc64 target) but present as late as GCC 4.6.2 (tested on the fedora-16-ppc64 target) as well as the GCC 4.4.6 release shipping with EPEL 6.

Compiling with -O1 (which is the default up to Gambit 4.6.3) works around this problem, but upstream points out that it's a GCC problem.

Upstream bug report: http://gcc.gnu.org/bugzilla/show_bug.cgi?id=52829
Comment 5 RHEL Product and Program Management 2012-05-03 01:31:49 EDT
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 6 RHEL Product and Program Management 2012-07-10 04:35:33 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 7 RHEL Product and Program Management 2012-07-10 19:14:32 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 9 RHEL Product and Program Management 2012-12-14 03:32:28 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 10 RHEL Product and Program Management 2014-09-30 12:35:52 EDT
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.