Bug 808288 - update gui (or commandline yum) fails with error 'yumBackend.py", line 2451' ( 'yum line 29' ... 'yummain.py, line 321')
update gui (or commandline yum) fails with error 'yumBackend.py", line 2451' ...
Status: CLOSED DUPLICATE of bug 808130
Product: Fedora
Classification: Fedora
Component: yum-presto (Show other bugs)
17
noarch Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Jonathan Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-30 00:20 EDT by collura
Modified: 2012-03-30 20:04 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 808130
Environment:
Last Closed: 2012-03-30 20:04:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description collura 2012-03-30 00:20:32 EDT
Description of problem:

 restate bug#808130 with error in subject line to aid searchability 
 to reduce duplicate filings :')

Version-Release number of selected component (if applicable):

 yum-presto-0.7.2-1.fc17.noarch

How reproducible:

  always

Steps to Reproduce:
1. run updater-gui (or yum from commandline)
2. select packages, install 
3. get error 

Actual results:

  update fails, 

  get error from gui:
    'File "/usr/share/PackageKit/helpers/yum/yumBackend.py", line 2451, 
     in _runYumTransaction rpmDisplay=rpmDisplay)
     File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 5629, 
     in processTransaction pkgs = self._downloadPackages(callback)'

  (or get error from command line:
    'File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
    File "/usr/share/yum-cli/yummain.py", line 321, in user_main
    errcode = main(args)'
  )

Expected results:

  update succeeds, 
  no error
  (no error)

Additional info:

  'yum downgrade yum-presto' to 
     yum-presto-0.7.1-2.fc17.noarch and 
  install 
     yum-presto-0.7.3-1.fc17.noarch 
  test update from koji seems to fix things nicely
Comment 1 Adam Williamson 2012-03-30 20:04:20 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 808130 ***

Note You need to log in before you can comment on or make changes to this bug.