This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 808317 - NFS: Kernel compilation is too slow
NFS: Kernel compilation is too slow
Status: CLOSED NOTABUG
Product: GlusterFS
Classification: Community
Component: nfs (Show other bugs)
pre-release
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vinayaga Raman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-30 02:37 EDT by Sachidananda Urs
Modified: 2014-03-30 21:28 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-27 08:33:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sachidananda Urs 2012-03-30 02:37:22 EDT
Kernel compilation takes forever when compiled on NFS mount. The same is pretty fast on FUSE mount. Nothing is listed in the NFS logs.

Reproducing is straight forward:

* Extract the kernel.
* Create a default config.
* make
Comment 1 Krishna Srinivas 2012-03-30 06:18:21 EDT
Sac, what is the setup like? can I access it?
Comment 2 Sachidananda Urs 2012-04-17 05:55:47 EDT
With ntpd stopped and ntpdate synced with pool.ntp.org (the time difference was in milliseconds). The compilation continues faster. However, this was not really consistent, it used to work sometimes and sometimes it didn't (depending on the distribution of files on the server). And in 3.2.6 slowness was never experienced at all.

We need to document his in our FAQ or somewhere.  Also, if the logging can somehow improved to detect this, it would help.
Comment 3 Vidya Sakar 2012-04-18 11:13:02 EDT
Removing the blocker flag as this looks like a setup issue.
Comment 4 Sachidananda Urs 2012-04-18 11:34:01 EDT
I am not sure if I have enough details to mark this as fixed. I could reproduce this today after disabling all sorts of caching is NFS.

Maybe we can mark this as known issue when caching is disabled?
Comment 5 Vijay Bellur 2012-04-27 08:33:04 EDT
With caching disabled, this would be expected. Hence we don't see the need for documenting expected behavior.

Note You need to log in before you can comment on or make changes to this bug.