Bug 808359 - SELinux is preventing /sbin/ldconfig from 'append' accesses on the soubor /usr/share/ati/fglrx-install.log.
SELinux is preventing /sbin/ldconfig from 'append' accesses on the soubor /us...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:0deaa84fb0b08b646a22babce46...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-30 05:00 EDT by czenda1985
Modified: 2012-03-30 13:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-30 13:58:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description czenda1985 2012-03-30 05:00:51 EDT
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.2.10-1.fc16.x86_64
reason:         SELinux is preventing /sbin/ldconfig from 'append' accesses on the soubor /usr/share/ati/fglrx-install.log.
time:           Pá 30. březen 2012, 11:00:30 CEST

description:
:SELinux is preventing /sbin/ldconfig from 'append' accesses on the soubor /usr/share/ati/fglrx-install.log.
:
:*****  Plugin catchall_labels (71.9 confidence) suggests  ********************
:
:If chcete povolit, aby ldconfig mělo přístup append k fglrx-install.log file
:Then you need to change the label on /usr/share/ati/fglrx-install.log
:Do
:# semanage fcontext -a -t FILE_TYPE '/usr/share/ati/fglrx-install.log'
:where FILE_TYPE is one of the following: ldconfig_t, admin_home_t, user_cron_spool_t, ldconfig_cache_t, logfile, user_tmp_t, user_tmp_t, logfile, rpm_script_tmp_t, sosreport_tmp_t, abrt_var_cache_t, rpm_tmp_t, cache_home_t, user_home_t, user_home_t, ld_so_cache_t, puppet_tmp_t, puppet_tmp_t, ldconfig_tmp_t. 
:Then execute: 
:restorecon -v '/usr/share/ati/fglrx-install.log'
:
:
:*****  Plugin catchall (14.7 confidence) suggests  ***************************
:
:If you believe that ldconfig should be allowed append access on the fglrx-install.log file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep ldconfig /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:*****  Plugin leaks (14.7 confidence) suggests  ******************************
:
:If you want to ignore ldconfig trying to append access the fglrx-install.log file, because you believe it should not need this access.
:Then you should report this as a bug.  
:You can generate a local policy module to dontaudit this access.
:Do
:# grep /sbin/ldconfig /var/log/audit/audit.log | audit2allow -D -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:system_r:ldconfig_t:s0-s0:c0.c1023
:Target Context                unconfined_u:object_r:usr_t:s0
:Target Objects                /usr/share/ati/fglrx-install.log [ file ]
:Source                        ldconfig
:Source Path                   /sbin/ldconfig
:Port                          <Neznámé>
:Host                          (removed)
:Source RPM Packages           glibc-2.14.90-24.fc16.6.x86_64
:                              glibc-2.14.90-24.fc16.6.i686
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-78.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.2.10-1.fc16.x86_64 #1 SMP Mon
:                              Mar 12 22:34:35 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    Pá 30. březen 2012, 06:07:27 CEST
:Last Seen                     Pá 30. březen 2012, 06:07:27 CEST
:Local ID                      c72a1bee-d3b5-4156-b009-6c805a370662
:
:Raw Audit Messages
:type=AVC msg=audit(1333080447.127:314): avc:  denied  { append } for  pid=13398 comm="ldconfig" path="/usr/share/ati/fglrx-install.log" dev=sda13 ino=1313131 scontext=unconfined_u:system_r:ldconfig_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:usr_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1333080447.127:314): arch=x86_64 syscall=execve success=yes exit=0 a0=228da80 a1=228d730 a2=2271f10 a3=10 items=0 ppid=13100 pid=13398 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=tty3 ses=24 comm=ldconfig exe=/sbin/ldconfig subj=unconfined_u:system_r:ldconfig_t:s0-s0:c0.c1023 key=(null)
:
:Hash: ldconfig,ldconfig_t,usr_t,file,append
:
:audit2allow
:
:#============= ldconfig_t ==============
:allow ldconfig_t usr_t:file append;
:
:audit2allow -R
:
:#============= ldconfig_t ==============
:allow ldconfig_t usr_t:file append;
:
Comment 1 Daniel Walsh 2012-03-30 13:58:10 EDT
 /usr/share/ati/fglrx-install.log  is a horrible location for a log file, so I will not fix this.  Open a bug with ati to put their log file in a reasonable place like /var/log

You can ignore this since nothing broke or change the label on the file

# semanage fcontext -a -t var_log_t  /usr/share/ati/fglrx-install.log 
# restorecon  /usr/share/ati/fglrx-install.log

Note You need to log in before you can comment on or make changes to this bug.