Bug 808370 - Monitoring - Probe "Linux: Process Health" - configuration issue
Monitoring - Probe "Linux: Process Health" - configuration issue
Status: CLOSED WONTFIX
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
1.7
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Michael Mráka
Red Hat Satellite QA List
:
Depends On:
Blocks: space18
  Show dependency treegraph
 
Reported: 2012-03-30 05:35 EDT by Dimitar Yordanov
Modified: 2012-11-01 12:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-31 10:39:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dimitar Yordanov 2012-03-30 05:35:08 EDT
Description of problem:
When configuring probe "Linux: Process Health"
 parameter 
  "Command name:"
 or
  "PID file (overrides command name):"
 have to be specified but none of those parameters is marked as compulsory.

Version-Release number of selected component (if applicable):
SW17

How reproducible:
100%	

Steps to Reproduce:
1. SW 1.7 with Enables Monitoring
   Admin -> Spacewalk Configuration -> Enable Monitoring
   Admin -> Spacewalk Configuration -> Monitoring -> Enable Monitoring Scout
   Restart SW

2. Create Probe Suite
    Monitoring -> Probe Suites
3. Add "Linux: Process Health" Prob to the Probe Suite
     Monitoring -> Probe Suites -> Your Suit -> Probes -> create new probe ->
Linux: Process Health

   NB:  Leave  the following fields empty.
          "Command name:"
          "PID file (overrides command name):"
4. Press button "Create Probe"

Actual results:
The probe will be created and fail latter because no PID or Command name is specified.

Expected results:
Probe creation fails if no value is provided both "Command name:" and "PID file (overrides command name):".


Additional info:
Comment 1 Miroslav Suchý 2012-04-23 07:09:42 EDT
This is not easy. Parameters of probes are defined in RHN_COMMAND_PARAMETER, by column MANDATORY: CHAR(1). If this is something else then NULL, then it is mandatory.
So this will either require to create new table with relation which parameters is mandatory, but replaceable. And write completly new framework around it.

Or in java/code/src/com/redhat/rhn/domain/monitoring/command/ParameterValidator.java
hardcode this one form into isMandatory().

First approach is very hard and will take a lot of resource. Second is very ugly.
Since this is not regression and severity is very low, I'm punting it to sat600-triage.
Comment 2 Jan Pazdziora 2012-07-31 10:39:00 EDT
Per comment 1, closing as WONTFIX(it's hard).

Note You need to log in before you can comment on or make changes to this bug.