Bug 80838 - Kickstart file generation problem
Kickstart file generation problem
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-31 15:29 EST by Alan Becker
Modified: 2007-04-18 12:49 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-25 10:59:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Becker 2002-12-31 15:29:52 EST
Description of problem:
Under Custom installs, if individual package selections are modified during the "Package Group" selection phase (by 
clicking Details, then altering the checkbox list shown),  those changes are not reflected in the Anaconda-generated 
Kickstart file.  In such a situation, the generated Kickstart file can NOT be used to duplicate the installation process.

Version-Release number of selected component (if applicable):


How reproducible:
Every time

Steps to Reproduce:
1. Perform a "Custom" install of RedHat 8.0.  During "Package Group Selection", click on Details at least once, and change 
the list of selected packages (when choosing packages to select or deselect, try for some without many dependencies)
2.  Complete the installation.  Boot up and save the /root/anaconda-ks.cfg file, and also capture the RPM list, either saving 
/root/install.log, or using "rpm -qa | sort >rpm.lst" and saving the result file.
3. Set up a Kickstart floppy, using the generated kickstart file from step 1 without modification.  Re-do the installation 
using this Kickstart floppy.
4. Boot the re-installed system.  Capture the rpm list using the same method used in step 2.  Compare the 
new rpm list to the original rpm list from step 2.
    
Actual results:
The 2 rpm lists will differ.  Any/all individual package selection adjustments made in Step 1 will have been ignored 
during the Kickstart reinstall, unless those packages were affected by other dependencies.  It is as if these changes 
were not included in the manufacture of the generated Kickstart file.

Expected results:
The 2 rpm lists should have been identical.

Additional info:
If this is actually intended behavior, I would like someone to explain to me why this is the case.  As the ability to 
make such adjustments is rather new (it didn't exist in 7.2, haven't checked 7.3) the most likely explanation would 
seem to be that someone simply forgot to include these adjustments when generating the kickstart file.
Comment 1 Jeremy Katz 2003-01-03 00:28:51 EST
Should be identical and phoebe does better, but it's still not 100% -- getting
there, though
Comment 2 Jeremy Katz 2003-02-11 23:43:11 EST
Fixed in CVS
Comment 3 Brent Fox 2003-05-25 10:59:11 EDT
I'm going through Bugzilla closing some bugs that have been marked as Modified
for some period of time.  I believe that most of these issues have been fixed,
so I'm resolving these bugs as Rawhide.  If the bug you are seeing still exists,
please reopen this report and mark it as Reopened.

Note You need to log in before you can comment on or make changes to this bug.