Bug 808413 - Dependency on python-argparse
Dependency on python-argparse
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: python-keystoneclient (Show other bugs)
el6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alan Pevec
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-30 06:59 EDT by Derek Higgins
Modified: 2012-04-21 16:59 EDT (History)
4 users (show)

See Also:
Fixed In Version: python-keystoneclient-2012.1-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-21 16:59:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Derek Higgins 2012-03-30 06:59:57 EDT
Dependency on python-argparse needs to be added to python-keystoneclient

its imported in  shell.py

[root]# grep "import argparse" keystoneclient/shell.py
import argparse
Comment 1 Cole Robinson 2012-04-02 17:06:26 EDT
Hmm, on my F16 box:

$ rpm -qf /usr/lib64/python2.7/argparse.py
python-libs-2.7.2-5.2.fc16.x86_64

So no explicit dep needed AFAICT. Closing as NOTABUG, please reopen if I missed something
Comment 2 Derek Higgins 2012-04-02 17:48:02 EDT
Sorry Cole, the bug should have been against epel 6 not F17, I'll see if I can update the version in the description

more details below

[root@rhel62dh ~]# yum install -y --enablerepo=epel-testing python-keystoneclient 
[root@rhel62dh ~]# rpm -qa | grep -i keystone
python-keystoneclient-2012.1-0.5.e4.el6.noarch
[root@rhel62dh ~]# keystone 
Traceback (most recent call last):
  File "/usr/bin/keystone", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 2655, in <module>
    working_set.require(__requires__)
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 648, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 546, in resolve
    raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: argparse
[root@rhel62dh ~]#
Comment 4 Fedora Update System 2012-04-05 15:56:22 EDT
python-keystoneclient-2012.1-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/python-keystoneclient-2012.1-1.el6
Comment 5 Fedora Update System 2012-04-06 17:06:09 EDT
Package python-keystoneclient-2012.1-1.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing python-keystoneclient-2012.1-1.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2012-0981/python-keystoneclient-2012.1-1.el6
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-04-21 16:59:58 EDT
python-keystoneclient-2012.1-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.