Bug 80842 - Ambiguous and Missing Prompts in Graphical Package manager
Ambiguous and Missing Prompts in Graphical Package manager
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-packages (Show other bugs)
8.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jonathan Blandford
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-31 17:59 EST by Need Real Name
Modified: 2013-04-02 00:17 EDT (History)
4 users (show)

See Also:
Fixed In Version: FC5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-19 17:54:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-12-31 17:59:19 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:

Accessing the package manager graphically has a better design than in 7.x, but
needs to communicate better with the naive user.  The following ambiguities and
unclearnesses exist:

1: Use of unexplained jargon -- Perhaps it's useful to use jargon in menus, but
the balloon help should explain it, not repeat it.
   Jargon                 Proposed balloon
   "Packages"        "Change programs, tools, and software suites"
   "Package Management"  "Add, Remove, or change software installed"

2: Vagueness -- It's not clear that package management belongs in "System
Settings" rather than "System Tools."  Isn't it a tool?  It doesn't "set"
anything in particular, does it?  If you're not sure which menu to put it under,
why not put it under both?  Redundancy can be a virtue...

A: If you need to keep the menu title short ("Packages"), then make the balloon
help actually descriptive.  Instead of "Manage packages installed on the system"
-- which doesn't explain the jargon terms "manage" or "package" -- it would be
more useful to say "Add, Remove, or change installed software" in the balloon.

B:  The password dialog box says, generically, "You are attempting to run
"redhat-config-packages" which requires administrative privileges, but more
information is required to do so."  Your attempt to create a generic password
dialog box has run aground on vagueness.  What is communicated by "but more
information is required to do so" that "please type the root password" does not?

C: The package name appears ONLY in this string; it does not appear elsewhere in
the package-management process.  This presents a real challenge to the
inexperienced user who is trying diligently to use bugzilla properly to report a
bug.  Nowhere is it clear which alias is the name of the process!  Is it
"Package Management" (the name on the final package selection window)?  Is it
"Packages" (the menu item selected to begin the process)? Is it
rpm-config-packages?  The user ends up guessing which term actually is the
process name and which names are alaises.

3: Ambiguity -- (i.e., unclear alternatives)

A: When the "Package Management" window is reached, no clue is offered the user
on how installed packages are indicated.  Does the open box mean that the
package doesn't need to be installed because it's already on the system?  Or
does the X'd box mean that the particular component was found during the scan?

B: And when the user wants to Delete an installed package, is this done by X'ing
the box to indicate that it's to be deleted, or by un-X'ing the box?  How is the
user to understand that un'X'ing a box will actually cause an action be be
taken?  An open box might just mean "take no action."

C:  The action-button is labelled "Update."  Whoa!  How is this different from
"up2date"?  How is the user to know, given all the aliases that have appeared in
the 8.0 menus (presumably to defuse some of the intimidating Linux jargon),
whether up2date is run along with package installation or deletion?  If the user
knows about up2date, he will hope and expect that the process invokes up2date or
in any case the latest version will be installed for any package chosen for
installation -- but what if the user is without an internet connection, or is
stuck with a really slow one, and wants to use his distribution CD's -- if he
can remember where he put that darned box?

How about "Make Changes" ??

OK, thanks for listening.

Version-Release number of selected component (if applicable):
Red Hat 8.0

How reproducible:
Always

Steps to Reproduce:
Not applicable  

Actual Results:  Not applicable

Expected Results:  Clear and unambiguous descriptive English.

Additional info:

I list "severe memory leak" allegorically...
Comment 1 Jeremy Katz 2003-01-01 22:00:14 EST
Jonathan -- I'm going to defer to use on these
Comment 2 Alfonso 2003-04-08 13:05:25 EDT
on top of all the vagueness...there seems to be huge problems with dependencies.
 i installed RH9 quick and dirty last week and forgot to include the development
packages.  when i started RH i logged in and ran all of the updates from the
up2date.  rebooted...now that i go to install the development packages, it says
it can't find openssl and krb5, even though they ARE installed, i think they
were just updated from up2date...it doesn't even let me move on without
openssl-devel and krb5-libs-devel or whatever, i have no choice.  i can only
quit.  help!

PS this is on RH9
Comment 3 Jeremy Katz 2006-04-19 17:54:31 EDT
We've tried to make improvements in this area for the next-generation tool

Note You need to log in before you can comment on or make changes to this bug.