Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 808468 - Jenkins builds fail while git push an application with jenkins server
Summary: Jenkins builds fail while git push an application with jenkins server
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OKD
Classification: Red Hat
Component: Containers
Version: 2.x
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Bill DeCoste
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-03-30 13:43 UTC by bzhao
Modified: 2015-05-14 22:52 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-31 02:22:40 UTC
Target Upstream Version:


Attachments (Terms of Use)
jenkins_log (11.92 KB, text/x-log)
2012-03-30 13:44 UTC, bzhao
no flags Details

Description bzhao 2012-03-30 13:43:04 UTC
Description of problem:
It will output '**BUILD FAILED/CANCELLED**...' 

Version-Release number of selected component (if applicable):
rhc-0.89.10-1.el6_2.noarch
rhc-cartridge-jenkins-1.4-0.89.2-1.el6_2.noarch
rhc-broker-0.89.7-1.el6_2.noarch

How reproducible:
sometimes

Steps to Reproduce:
1.Create any type of application
# rhc-create-app -t php-5.3 -p xxx -a phptest
2.Create an jenkins application
# rhc-create-app -t jenkins-1.4 -p xxx -a jenkinstest
3.Embedded jenkins to the application
# rhc-ctl-app -p xxx -e add-jenkins-client-1.4 -a phptest
4.Git push the application
  
Actual results:
Jenkins builds fail

Expected results:
Jenkins builds successfully without any error

Additional info:

Comment 1 bzhao 2012-03-30 13:44:02 UTC
Created attachment 573984 [details]
jenkins_log

Comment 2 Dan McPherson 2012-03-30 16:47:43 UTC
At first glance it looks like a dns timeout.

Comment 3 Johnny Liu 2012-03-31 02:22:40 UTC
"Timeout" is by design. Refer to 807260 for more details.


Note You need to log in before you can comment on or make changes to this bug.