Bug 80851 - Weird message at boot -> vgchange - no volume groups change
Weird message at boot -> vgchange - no volume groups change
Status: CLOSED DUPLICATE of bug 81168
Product: Red Hat Linux
Classification: Retired
Component: lvm (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Stephen Tweedie
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-31 21:35 EST by Thiago Sayao
Modified: 2007-04-18 12:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-31 09:31:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thiago Sayao 2002-12-31 21:35:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
I get this message lots of times at boot (on init):
vgchange - no volume groups change


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Turn on your computer
2. Choose Rh beta on grub.
3. Watch the init messages.
    

Additional info:
Comment 1 Bill Nottingham 2002-12-31 21:58:08 EST
What sort of partitioning setup do you have?
Comment 2 Thiago Sayao 2003-01-01 10:15:45 EST
Disk /dev/hde: 41.1 GB, 41110142976 bytes
16 heads, 63 sectors/track, 79656 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes
 
   Device Boot    Start       End    Blocks   Id  System
/dev/hde1             1       610    307408+  82  Linux swap
/dev/hde2   *       611     79656  39839184   83  Linux
Comment 3 Bill Nottingham 2003-01-01 20:59:33 EST
Is that your only hard drive?
Comment 4 Thiago Sayao 2003-01-02 18:40:30 EST
Its the only with the cables connected :) The other one is disconnected (both
power and IDE cable). I also have a CDROM.

/dev/hde is connected with a 80pin cable on a promise onboard controller (the
one that comes with Asus A7A 133).

/dev/cdrom is connected on the via controller.
Comment 5 Bill Nottingham 2003-01-02 20:58:49 EST
Do you have an /etc/lvmtab?
Comment 6 Thiago Sayao 2003-01-02 21:09:52 EST
Yes, i have, but its an empty file.
Comment 7 Bill Nottingham 2003-01-02 21:12:03 EST
Empty, zero-byte file? What happens if you remove it?
Comment 8 Thiago Sayao 2003-01-02 21:17:57 EST
[root@zeus etc]# ls -la lvmtab
-rw-r-----    1 root     root            1 Jan  2 21:41 lvmtab
[root@zeus etc]# cat lvmtab
[root@zeus etc]#

Its not zero-byte, but its empty.

Ive removed it (nothing happened) but i cant reboot the machine right now, i
will post the results tomorrow. Thanks.
Comment 9 Thiago Sayao 2003-01-04 19:32:57 EST
Yeo. Deleting that file made the messages disappear.
Comment 10 Bill Nottingham 2003-01-06 15:51:50 EST
OK, apparently at one point vgscan made a weird lvmtab file. I don't think
there's much the initscripts can do about this.
Comment 11 Stephen Tweedie 2003-01-06 17:06:10 EST
What is the history of that lvmtab file?  Did you create and then delete any
logical volumes?  Or was this happening ever since you installed the system?
Comment 12 Thiago Sayao 2003-01-06 21:30:01 EST
Just installed the system on an empty partiton and booted it. I didnt change the
disks/partitions after the install.
Comment 13 Josiah Royse 2003-01-13 09:38:19 EST
This is the same issue as Bug #81168 which is under anaconda, fixed in CVS.
Comment 14 Stephen Tweedie 2003-01-13 09:43:43 EST
Thanks for spotting that, Josiah.

*** This bug has been marked as a duplicate of 81168 ***

Note You need to log in before you can comment on or make changes to this bug.