Bug 80858 - associated programs with file types (issues)
associated programs with file types (issues)
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: nautilus (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-31 23:29 EST by John J. Germs
Modified: 2015-01-07 19:02 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-04 08:59:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John J. Germs 2002-12-31 23:29:58 EST
Description of problem:
After editing file types (associating programs with file types)
there is no way to remove entries from the
"open with" menu (right-click on file, open with)

Version-Release number of selected component (if applicable):


How reproducible:
See additional info section.

Steps to Reproduce:
1.
2.
3.
    
Actual results:
A list of programs (some no longer viable) I'd like to
remove from the Open With menu.

Expected results:
Be able to determine which programs show up in the Open With menu.

Additional info:

As an example:
Right-click on a .mp3 file, select 'open with', other application.
A new window will open (Open with Other Application)
There will be a couple of programs listed there under:
Choose an application with which to open "foobar.mp3"
Since I want to associate a different player than what is
in the list I will select from the File Types and Programs,
Go There
This now brings up a new window Edit file type:
In the Program to run:
I type in the name of my program... 

If I do this a few times and add associate some programs
they will show up in the 'open with' menu...
If lets say one of these associated programs has a glitch
and I want to remove it from the menu there is now way to
do this.
Sure I am able to remove any of the programs that are
listed in the (Open with Other Application) window,
-------snip------
Right-click on a .mp3 file, select 'open with', other application.
A new window will open (Open with Other Application)
There will be a couple of programs listed there under:
Choose an application with which to open "foobar.mp3"
-------snip------
but my added programs aren't listed there... 
Is this maybe the problem??.. Are they supposed to be listed there
and aren't??... If they were I'd be able to specify which are shown, etc.
Comment 1 Alexander Larsson 2003-01-16 06:26:05 EST
It seems the "custom" entry you can change in the control-center "File tyeps and
programs" window is never used by nautilus. This is basically another "gnome
mimetype handling sucks" bug.
Comment 2 Alexander Larsson 2004-10-04 08:59:02 EDT
Should work in gnome 2.8.0

Note You need to log in before you can comment on or make changes to this bug.