Bug 808595 - yum update fails and hangs (has to be killed)
Summary: yum update fails and hangs (has to be killed)
Keywords:
Status: CLOSED DUPLICATE of bug 808130
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 17
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-03-30 19:30 UTC by Arne Ahrend
Modified: 2014-01-21 23:21 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-04-01 11:00:53 UTC
Type: ---


Attachments (Terms of Use)

Description Arne Ahrend 2012-03-30 19:30:10 UTC
Description of problem:


Version-Release number of selected component (if applicable): 3.4.3


How reproducible: call "yum update" as root from command line


Steps to Reproduce:
1. Boot F17 alpha, log into Gnome, open terminal, su - into root account
2. yum update
3. wait for list of affected packages to scroll by and confirm with "y"
  
Actual results:
Transaction Summary
================================================================================
Install    2 Packages (+4 Dependent packages)
Upgrade  179 Packages

Total download size: 234 M
Is this ok [y/N]: y
Downloading Packages:
Setting up and reading Presto delta metadata
Processing delta metadata
Traceback (most recent call last):
  File "/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 321, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 229, in main
    return_code = base.doTransaction()
  File "/usr/share/yum-cli/cli.py", line 547, in doTransaction
    problems = self.downloadPkgs(downloadpkgs, callback_total=self.download_callback_total_cb) 
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 2147, in downloadPkgs
    self.plugins.run('predownload', pkglist=pkglist)
  File "/usr/lib/python2.7/site-packages/yum/plugins.py", line 187, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/presto.py", line 633, in predownload_hook
    (problems, more) = downloadPkgs(conduit, pinfo, download_pkgs)
  File "/usr/lib/yum-plugins/presto.py", line 321, in downloadPkgs
    delta = getDelta(po, presto, conduit, conf_mp)
  File "/usr/lib/yum-plugins/presto.py", line 198, in getDelta
    conduit.info(5, -("Could not find delta rpm for package %s.%s.")
TypeError: bad operand type for unary -: 'str'


^C^C^C

^Z
[1]+  Stopped                 yum update
[root@f17a ~]# kill %1

[1]+  Stopped                 yum update
[root@f17a ~]# 
[1]+  Terminated              yum update


Expected results:
system updated to newest available packages

Additional info:
df -h /var/lib/yum/history
Filesystem      Size  Used Avail Use% Mounted on
/dev/sda2        28G  5.4G   21G  21% /

Comment 1 Jonathan Dieter 2012-04-01 11:00:53 UTC
This is a duplicate of bug 808130.

To update the buggy yum-presto, run
yum --disablepresto update yum-presto

*** This bug has been marked as a duplicate of bug 808130 ***

Comment 2 Fedora Update System 2012-04-03 18:23:52 UTC
libpng10-1.0.59-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2012-0928/libpng10-1.0.59-1.el6


Note You need to log in before you can comment on or make changes to this bug.