Bug 808611 - gtick 0.5.1 is available
gtick 0.5.1 is available
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gtick (Show other bugs)
17
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-30 16:21 EDT by Artyom Kunyov
Modified: 2013-03-19 16:07 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-19 16:02:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
specfile patch (1.35 KB, patch)
2013-02-27 22:50 EST, Dave Allan
no flags Details | Diff

  None (edit)
Description Artyom Kunyov 2012-03-30 16:21:44 EDT
Description of problem:

Gtick has recently been updated to 0.5.0, which contains at least one very important feature - pulseaudio support. I've built it from source on my F16 machine, and it works fine. I think it should be updated before the F17 is released. Thank you.
Comment 1 Artyom Kunyov 2012-07-26 10:01:48 EDT
Bumping this, pulseaudio support in 0.5.1 is a very important feature.
Comment 2 Artyom Kunyov 2012-11-30 08:35:39 EST
Still no news on this?
Comment 3 Artyom Kunyov 2012-11-30 08:35:59 EST
Still no news on this?
Comment 4 Dave Allan 2013-02-27 22:50:37 EST
Created attachment 703766 [details]
specfile patch

Just for grins,	I spun a scratch build of 0.5.1 at:

http://koji.fedoraproject.org/koji/taskinfo?taskID=5063072

My spec-fu is a	little stale, but it built and installed ok on my F17
system.  Anybody with a little more skill in these things willing to take a look and push the changes to rawhide if they look sane?  I've attached a diff of the spec changes I made.
Comment 5 Nils Philippsen 2013-02-28 08:05:21 EST
Hm, this bug was assigned to the previous owner (this is why I didn't notice it right away).

I see you've built in pulseaudio support, I want to check if it's feasible to have this modular somehow.
Comment 6 Dave Allan 2013-02-28 08:23:06 EST
(In reply to comment #5)
> I see you've built in pulseaudio support, I want to check if it's feasible
> to have this modular somehow.

Yeah, that's why I wanted the update, so I just did it unconditionally. :)  You mean you'd like to have it use pulse if it's there but not require it?
Comment 7 Nils Philippsen 2013-02-28 11:23:20 EST
Dave, thanks for the heads-up. Apparently gtick doesn't use modules for OSS, alsa, pulseaudio, etc. This is something upstream should think about if they add jack support at some point...

Anyway, I've kust kicked off builds of 0.5.1 in F17..Rawhide, with some additional modifications:

- don't manually require pulseaudio -- it gets pulled in via the linked libraries
- build with libsndfile, allowing custom "click" sounds, fix a crash related to that
Comment 8 Artyom Kunyov 2013-02-28 12:23:02 EST
I have just installed F17 build from koji, and it seems to work fine... except one thing. Click sound is really ugly. On another machine, I have gtick 0.5.1 built from source, and it sounds different with the same settings.
Comment 9 Dave Allan 2013-02-28 13:44:29 EST
(In reply to comment #7)
> - build with libsndfile, allowing custom "click" sounds, fix a crash related
> to that

The default and sine settings in F17 build from koji work nicely for me.  I do get a not entirely reproducible segfault with custom click sounds, but since that feature isn't available at all in the 0.4.2 build, I don't think that should stop updating 0.5.1.  I'll file a separate BZ about it.
Comment 10 Dave Allan 2013-02-28 22:21:28 EST
The crash is at dsp.c:250 which is the code that handles the case in which a custom click sound sample needs to be mixed down.  I have to admit I don't fully understand what it's doing or why sometimes mixdown is required and sometimes not, but gtick seems to crash reliably when it thinks mixdown is required.  I'm pretty sure that feature is not going to be stable in 0.5.1, so you might consider compiling it out until someone can figure out what's going on and patch it.  OTOH, there's an easy workaround: don't use custom click sounds.
Comment 11 Fedora Update System 2013-03-01 11:39:41 EST
gtick-0.5.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/gtick-0.5.1-1.fc17
Comment 12 Fedora Update System 2013-03-01 11:39:57 EST
gtick-0.5.1-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/gtick-0.5.1-1.fc18
Comment 13 Nils Philippsen 2013-03-01 11:55:06 EST
(In reply to comment #8)
> I have just installed F17 build from koji, and it seems to work fine...
> except one thing. Click sound is really ugly. On another machine, I have
> gtick 0.5.1 built from source, and it sounds different with the same
> settings.

(How) does this other machine differ from the machine you tried the F17 build on? How is the F17 click "ugly", while the other one isn't (just describe how both sound to you). Did you have the same issue with 0.4.x? Thanks.

(In reply to comment #10)
> The crash is at dsp.c:250 which is the code that handles the case in which a
> custom click sound sample needs to be mixed down.  I have to admit I don't
> fully understand what it's doing or why sometimes mixdown is required and
> sometimes not, but gtick seems to crash reliably when it thinks mixdown is
> required.  I'm pretty sure that feature is not going to be stable in 0.5.1,
> so you might consider compiling it out until someone can figure out what's
> going on and patch it.  OTOH, there's an easy workaround: don't use custom
> click sounds.

Hmm, I haven't seen another crash after I fixed the one I saw (if no valid sound file is configured). I've also left the feature in, as the workaround is easy :-). I'd be happy for another report, if there's a way for me to reproduce it.
Comment 14 Fedora Update System 2013-03-02 15:07:26 EST
Package gtick-0.5.1-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gtick-0.5.1-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-3264/gtick-0.5.1-1.fc17
then log in and leave karma (feedback).
Comment 15 Fedora Update System 2013-03-19 16:02:02 EDT
gtick-0.5.1-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2013-03-19 16:07:09 EDT
gtick-0.5.1-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.