Bug 808654 - [whql] [netkvm]NDISTest 6.5 job failed on windows 2008
Summary: [whql] [netkvm]NDISTest 6.5 job failed on windows 2008
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win
Version: 6.3
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Yvugenfi@redhat.com
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-03-31 03:16 UTC by Min Deng
Modified: 2012-06-20 11:58 UTC (History)
12 users (show)

Fixed In Version: build 27
Doc Type: Bug Fix
Doc Text:
No Documentation needed.
Clone Of:
Environment:
Last Closed: 2012-06-20 11:58:43 UTC
Target Upstream Version:


Attachments (Terms of Use)
guest1 (1.10 KB, application/x-sh)
2012-03-31 03:17 UTC, Min Deng
no flags Details
guest2 (944 bytes, application/x-sh)
2012-03-31 03:17 UTC, Min Deng
no flags Details
monitorerror (1.02 KB, application/octet-stream)
2012-03-31 03:19 UTC, Min Deng
no flags Details
An error message of installing win2k8-64 driver (63.16 KB, image/png)
2012-04-20 07:21 UTC, Min Deng
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0751 0 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2012-06-19 19:31:22 UTC

Comment 1 Min Deng 2012-03-31 03:17:04 UTC
Created attachment 574120 [details]
guest1

Comment 2 Min Deng 2012-03-31 03:17:31 UTC
Created attachment 574121 [details]
guest2

Comment 3 Min Deng 2012-03-31 03:19:29 UTC
Created attachment 574123 [details]
monitorerror

Comment 4 Min Deng 2012-03-31 03:21:17 UTC
seabios version,
seabios-0.6.1.2-4.el6.x86_64

Comment 6 Min Deng 2012-03-31 03:34:31 UTC
For windows 2008 32,the job only passed one time on AD ENV but it always failed in WORKGROUP ENV.

Thanks
Min

Comment 7 Mike Cao 2012-03-31 05:28:59 UTC
This is a testblocker for netkvm whql test 
what's more ,I use freshly installed image .

Comment 9 Mike Cao 2012-03-31 08:51:32 UTC
summary of the issue we hit 

1.sometimes NDIS client BSOD ,dump referring to comment #0
2.sometimes NDIS client virtio-nit can not get ip after the job running for a while 
3.sometimes job hang at "VLANSendRecv" sub-job ,in the DTM Studio ,the NDIS client shows in no-responsible status ,but ping DTM Studio in the guest works .

Comment 10 Mike Cao 2012-04-01 02:45:34 UTC
(In reply to comment #9)
> summary of the issue we hit 
> 
> 1.sometimes NDIS client BSOD ,dump referring to comment #0
> 2.sometimes NDIS client virtio-nit can not get ip after the job running for a
> while 
> 3.sometimes job hang at "VLANSendRecv" sub-job ,in the DTM Studio ,the NDIS
> client shows in no-responsible status ,but ping DTM Studio in the guest works .
another thing need to hightlight ,I found "virtio_ioport_write: unexpected address 0x13 value 0x0 " in a loop , and I tried to shutdown the vm ,guest hang at 
"Shutting down" 

Best Regards,
Mike

Comment 11 Mike Cao 2012-04-01 05:38:23 UTC
I check the history of our tesing results ,-23 works fine ,so ,this should be a regression in -24 .

Mike

Comment 12 Yvugenfi@redhat.com 2012-04-01 07:54:10 UTC
* Please indicate which jobs other than  "VLANSendRecv" had issues (Please always when indicating failures in NDISTest 6.5 or NDISTest 6.0 - write which exact sub-test failed).

* ""virtio_ioport_write: unexpected address 0x13 value 0x0 " in a loop" - it means that transfer is stack (we send a packet to QEMU but didn't receive the indication that it was transfer). We specifically added such behavior (writing to virtio ISR register) - in order to get the indication of this situation on the host.

* What is the difference on the host from the previous runs?

* Also - https://bugzilla.redhat.com/show_bug.cgi?id=807967 - if this is a host issues and in any case we have problems after powermanagment events, I see how some of the tests will fail.

Comment 19 Min Deng 2012-04-06 10:18:28 UTC
(In reply to comment #12)
> * Please indicate which jobs other than  "VLANSendRecv" had issues (Please
> always when indicating failures in NDISTest 6.5 or NDISTest 6.0 - write which
> exact sub-test failed).
  
  Today,I tried the bug on two guests windows 2k8 32/64 bits after downgrading qemu to 227.The results were following as below,windows 2008 64 bits hit 7E issue once and windows 2k8-32 hits comments 9.3 issue.Uploaded VLANSendRecv.html log and dump file to \\smamit.eng.lab.tlv.redhat.com\win-team\Public\QE\808654\6.5issue.
 Any issues please let me know.

Thanks
Min

Comment 20 Yvugenfi@redhat.com 2012-04-08 14:03:30 UTC
Hello Mike and Min,

Unfortunately I cannot see failure descriptions from CPK (i see only driver verifier logs on job logs) or from log in run000\VlanSendRecv.htm. If you know how to look at the specific failure description - please guid me how to do it. 

Regarding crash dumps - there is clear indication from the printout of the MS test driver and our debug printout that transfer is stuck and that's why test driver is calling "int 3".

I will dig dipper into dump files to get more information.

What I need from you:

1. Could you describe what exact gusts are failing? All Win7\Win8? Is there difference between 32bit\64bit?

2. Is there anything new in host network configuration?

3. Are you running with vhost? If yes, is it possible to make a test run without it?

4. Is it possible to test build 24 on older host version?


Thanks!

Comment 41 Min Deng 2012-04-20 07:21:11 UTC
Created attachment 578893 [details]
An error message of installing win2k8-64 driver

Comment 46 Vadim Rozenfeld 2012-04-20 21:55:32 UTC
According to Yan, the problem should be fixed in build 27:
http://download.devel.redhat.com/brewroot/packages/virtio-win-prewhql/0.1/27/win/virtio-win-prewhql-0.1.zip

Comment 47 errata-xmlrpc 2012-04-21 16:17:40 UTC
Bug report changed to ON_QA status by Errata System.
A QE request has been submitted for advisory RHBA-2011:12358-01
http://errata.devel.redhat.com/errata/show/12358

Comment 50 Min Deng 2012-04-24 06:31:03 UTC
Hi all,

   Considering that issue has been fixed on windows 2008 64 and 32 guests via virtio-win-prewhlq-0.1-27 and there was another bug for tracing windows 7 64 bits guest specially.QE think the bug was fixed now.
   Thanks for developer's work.
 
Best Regards
Min

Comment 51 Vadim Rozenfeld 2012-05-10 13:41:03 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No Documentation needed.

Comment 53 errata-xmlrpc 2012-06-20 11:58:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0751.html


Note You need to log in before you can comment on or make changes to this bug.