Bug 808656 - existing stopped app on stage becomes to idle
existing stopped app on stage becomes to idle
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Pod (Show other bugs)
1.x
Unspecified Unspecified
high Severity low
: ---
: ---
Assigned To: Jhon Honce
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-30 23:31 EDT by Meng Bo
Modified: 2012-04-27 16:45 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-27 16:45:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Meng Bo 2012-03-30 23:31:05 EDT
Description of problem:
stopped apps on old instance will change to idle status after upgrade and migration.

Version-Release number of selected component (if applicable):
stage 2.0.8

How reproducible:
always

Steps to Reproduce:
1.create some apps on old stage 
2.change the app status to 'stop'
3.after server upgrade and migration check if the app available.
  
Actual results:
the app becomes to idle status after server upgrade and migration.

Expected results:
the app should keep stop status.

Additional info:
Comment 1 Johnny Liu 2012-03-31 01:16:14 EDT
I also encounter this issue.  Maybe the above step is not enough to reproduce this issue, I clarify it more clear.

I have a stopped app on stage that is created a long time ago (maybe several sprint ago). Today, I try to access it, I find that my stopped app becomes "idled", after access my app url, the app wakes up from "idled" status.

Will stopped app also be "idled" on stage after no access for a long time?
Comment 2 Meng Bo 2012-03-31 02:02:37 EDT
this issue cannot be recreated on devenv migrate operation.
it only happens on stage environment.
Comment 3 Johnny Liu 2012-03-31 08:00:02 EDT
(In reply to comment #2)
> this issue cannot be recreated on devenv migrate operation.
> it only happens on stage environment.

Ignore this comments, because I can find a way to reproduce it.

After stop app, idle it again manually, this app wil be waked up by accessing app url.

Do some more dig, I found rhc-autoidler, found it will check all application, even already stopped app. So I think the root cause is that rhc-autoidler miss a filter to exclude already stopped apps.
Comment 4 Johnny Liu 2012-03-31 08:11:07 EDT
rhc-autoidler is never run in devenv.
Comment 5 Johnny Liu 2012-04-01 04:55:14 EDT
I think it is better to give a fix patch to rhc-idler. Because stopped app should NOT be "idled". When trying to idle a "stopped" app, should skip it, and this seems to make more sense.
Comment 6 Jhon Honce 2012-04-18 13:36:34 EDT
fixed in commit 10797174f2686396ea75c8bc687ee21ac8112c04
Comment 7 Johnny Liu 2012-04-18 23:35:06 EDT
This patch introduce a new issue, rhc-idler does NOT any more, I will open another bug (Bug 814024) to track it. After Bug 814024 is fixed, I will verify this bug.
Comment 8 Meng Bo 2012-04-20 00:56:49 EDT
checked on devenv_1732, issue has been fixed.
rhc-idler will not handle the stop status apps.

Note You need to log in before you can comment on or make changes to this bug.