This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 808700 - yum is unaible to update
yum is unaible to update
Status: CLOSED DUPLICATE of bug 808130
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-31 05:41 EDT by meanpt
Modified: 2014-01-21 18:21 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-01 03:27:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description meanpt 2012-03-31 05:41:30 EDT
Description of problem:
yum is not updating the system, reporting the next problem:

Traceback (most recent call last):
  File "/usr/share/PackageKit/helpers/yum/yumBackend.py", line 2451, in _runYumTransaction
    rpmDisplay=rpmDisplay)
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 5629, in processTransaction
    pkgs = self._downloadPackages(callback)
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 5653, in _downloadPackages
    probs = self.downloadPkgs(dlpkgs)
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 2147, in downloadPkgs
    self.plugins.run('predownload', pkglist=pkglist)
  File "/usr/lib/python2.7/site-packages/yum/plugins.py", line 187, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/presto.py", line 633, in predownload_hook
    (problems, more) = downloadPkgs(conduit, pinfo, download_pkgs)
  File "/usr/lib/yum-plugins/presto.py", line 321, in downloadPkgs
    delta = getDelta(po, presto, conduit, conf_mp)
  File "/usr/lib/yum-plugins/presto.py", line 198, in getDelta
    conduit.info(5, -("Could not find delta rpm for package $s.$s.")
TypeError: bad operand type for unary -: 'str'

Version-Release number of selected component (if applicable):
na

How reproducible:
running update manager

Steps to Reproduce:
1. open update manager
2. execute the updating list
3. the update isn't completed due to the error reported
  
Actual results:


Expected results:


Additional info: tryed to update on a terminal and despite doing the workarounds sugested by the system in the terminal, the problem persisted
Comment 1 Andre Robatino 2012-04-01 03:27:01 EDT
Closing as a duplicate of bug 808130. To update to the fixed version of yum-presto, do

yum --disablepresto update yum-presto

*** This bug has been marked as a duplicate of bug 808130 ***

Note You need to log in before you can comment on or make changes to this bug.