This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 808709 - Non-English keyboard does not work
Non-English keyboard does not work
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
x86_64 Linux
medium Severity medium
: beta
: 6.3
Assigned To: Fabian Deutsch
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-31 06:16 EDT by cshao
Modified: 2016-04-26 10:44 EDT (History)
10 users (show)

See Also:
Fixed In Version: ovirt-node-2.3.0-4.el6
Doc Type: Bug Fix
Doc Text:
Previously, changes to the Hypervisor keyboard configuration would not persist across reboots. The Hypervisor has been updated and it is now possible to select non-English keyboard layours and have the change persisted across reboots.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-19 10:20:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description cshao 2012-03-31 06:16:57 EDT
Description of problem:
Non-English keyboard does not work

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.3-20120330.0.el6 

How reproducible:
100%

Steps to Reproduce:
1. Prepare a German keyboard and insert to test machine.
2. Install RHEV-H and choose "German" keyboard layout as default. 
3. Enter keyboard menu, choose "German" keyboard layout and apply. 
4. Test German keyboard function.(e.g. z or y )
  
Actual results:
Using the German keyboard, input z, displayed “y", it should display z when input z

Expected results:
Non-English keyboard work correctly.

Additional info:
Comment 9 Fabian Deutsch 2012-04-16 14:28:18 EDT
Tested upstream with this two patches:

http://gerrit.ovirt.org/3587
http://gerrit.ovirt.org/3588

Test procedure:
- Install node with the german keyboard layout and reboot
= Press the "y" key at the at the login prompt, a "y" appears
- Remove the "y" and loggin with admin
- Select the Network page
- Enter the hostname field
= Press the keys "y!&()z" (after each other), "y!&()z" is appended
- Remove the appended string
- Select the Keyboard page
- Select the "U.S. International" layout and apply
- Select the Network page
= Enter the hostname field and press the "y" key, a "z" appears
- Select the keyboard page, select the "german" keyboard layout and apply
- Reboot
= Press the "y" key at the login prompt, a "y" appears
- Login with admin
- Enter the Network page and enter the hostname field
- Press the "y" key, a "y" appears
Comment 14 Mike Burns 2012-06-13 13:14:26 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, selecting a non-English keyboard would not actually change the keyboard correctly.  Now, the chosen keyboard is used correctly.
Comment 15 Stephen Gordon 2012-06-13 19:36:16 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-Previously, selecting a non-English keyboard would not actually change the keyboard correctly.  Now, the chosen keyboard is used correctly.+Previously, changes to the Hypervisor keyboard configuration would not persist across reboots. The Hypervisor has been updated and it is now possible to select non-English keyboard layours and have the change persisted across reboots.
Comment 17 errata-xmlrpc 2012-07-19 10:20:33 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0741.html

Note You need to log in before you can comment on or make changes to this bug.