Bug 808710 - llvmpipe driver doesn't render correctly on Dell Inspiron Mini 10
llvmpipe driver doesn't render correctly on Dell Inspiron Mini 10
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
17
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F17Blocker/F17FinalBlocker
  Show dependency treegraph
 
Reported: 2012-03-31 06:21 EDT by Jiri Eischmann
Modified: 2012-04-09 14:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-09 14:13:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Smolt profile (2.46 KB, text/plain)
2012-03-31 06:21 EDT, Jiri Eischmann
no flags Details
Screenshot of the problem (561.55 KB, image/jpeg)
2012-03-31 06:22 EDT, Jiri Eischmann
no flags Details
Incorrect rendering in KDE (749.97 KB, image/jpeg)
2012-03-31 08:09 EDT, Jiri Eischmann
no flags Details
Xorg log (19.47 KB, application/octet-stream)
2012-04-04 10:51 EDT, Jiri Eischmann
no flags Details

  None (edit)
Description Jiri Eischmann 2012-03-31 06:21:50 EDT
Created attachment 574159 [details]
Smolt profile

Description of problem:
Software rendering doesn't render properly on Dell Inspiron Mini 10. There are artefacts in both upper corners and there is a black bar on the bottom of the screen. It doesn't seem to be specific to any desktop environment. It behaved pretty much the same both in GNOME Shell and Xfce (tested on the build for soft-rendering test day)


How reproducible:
Just boot into one of display managers
  
Actual results:
Broken rendering

Expected results:
Correct rendering via llvmpipe or blacklisting the driver and using another driver, Poulsbo should have a working driver in kernel 3.3, right?

Additional info:
I'm attaching a smolt profile and screenshot.
Comment 1 Jiri Eischmann 2012-03-31 06:22:39 EDT
Created attachment 574160 [details]
Screenshot of the problem
Comment 2 Jiri Eischmann 2012-03-31 06:32:52 EDT
I think this will affect all users with GMA500 and similar cards which is why I'm proposing it as a blocker bug for Fedora 17.
Comment 3 Jiri Eischmann 2012-03-31 08:09:16 EDT
Created attachment 574191 [details]
Incorrect rendering in KDE
Comment 4 Adam Jackson 2012-04-02 11:20:10 EDT
(In reply to comment #0)
> Expected results:
> Correct rendering via llvmpipe or blacklisting the driver and using another
> driver, Poulsbo should have a working driver in kernel 3.3, right?

Poulsbo has a driver in 3.3, yes.  The question is whether it works.

Do you see this corruption if you use forced-fallback mode in gnome?  If so then this isn't llvmpipe's fault.  You can set forced fallback in the System Info control panel, in the Graphics subsection.
Comment 5 Jiri Eischmann 2012-04-02 12:53:56 EDT
(In reply to comment #4)
> (In reply to comment #0)
> > Expected results:
> > Correct rendering via llvmpipe or blacklisting the driver and using another
> > driver, Poulsbo should have a working driver in kernel 3.3, right?
> 
> Poulsbo has a driver in 3.3, yes.  The question is whether it works.
> 
> Do you see this corruption if you use forced-fallback mode in gnome?  If so
> then this isn't llvmpipe's fault.  You can set forced fallback in the System
> Info control panel, in the Graphics subsection.

llvmpipe is used only when there is a compositor with "3D effects"? Because it was pretty much the same in KDE and Xfce which don't use 3D effects in Fedora by default. What is used then? Vesa or the Poulsbo driver in this case?

I'll get back to that computer on Friday.
Comment 6 Jiri Eischmann 2012-04-04 10:51:42 EDT
Created attachment 575163 [details]
Xorg log
Comment 7 Jiri Eischmann 2012-04-04 11:07:27 EDT
I looked at it today again.
I tried to log out and in GDM the screen wasn't suddenly broken any more. When I logged into fallback mode, it worked, too. When I enabled GNOME Shell again and logged into it, it worked, too.
Yes, the performance is horrible, but what else to expect from a netbook and software rendering.

I will look at the PSB-GFX driver if it works well at least for 2D. Anyone knows what the driver is capable of in kernel 3.3?
Comment 8 Adam Jackson 2012-04-09 14:13:39 EDT
The psb driver in 3.3 is unaccelerated.

Since it sounds like rendering is correct now I'm closing this out.  Thanks for the report.

Note You need to log in before you can comment on or make changes to this bug.