Bug 808721 - [RFE] Make sure ABRT stores the first not-tainted oops
[RFE] Make sure ABRT stores the first not-tainted oops
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: abrt (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: beta
: 6.4
Assigned To: abrt
David Kutálek
: FutureFeature, Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-31 06:40 EDT by David Jaša
Modified: 2013-02-21 02:53 EST (History)
7 users (show)

See Also:
Fixed In Version: abrt-2.0.8-8.el6
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 02:53:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Jaša 2012-03-31 06:40:40 EDT
Description of problem:
suggest what to blacklist to reproduce behaviour of tainted kernel on clean debuggable kernel

Version-Release number of selected component (if applicable):
abrt-2.0.8-4.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. an oops or tainted kernel occurs
2.
3.
  
Actual results:
abrt only says that the kernel is tainted:
not-reportable: A kernel problem occurred, but your kernel has beentainted (flags:G        W  ). Kernel maintainers are unable todiagnose tainted reports.

Expected results:
in addition to above line in Details of the crash, add another line like this:
kernel-tainted-by: <list_of_modules_that_taint_the_kernel>

Additional info:
Comment 1 Jiri Moskovcak 2012-06-12 10:19:06 EDT
Is it even possible to find out this information?
Comment 2 David Jaša 2012-06-13 10:38:36 EDT
I think that kernel should log waht tainted it.

BTW after I reported this bug, I learned why the kernel got tainted in my case - it got tainted by first warning, not by some module. The abrt's dedupe mechanism then merged three duplicate warnings to the latest one and then discarded everything (IIRC I reported this in a separate bug).
Comment 3 Jiri Moskovcak 2012-06-13 11:25:08 EDT
(In reply to comment #2)
> I think that kernel should log waht tainted it.
> 
> BTW after I reported this bug, I learned why the kernel got tainted in my
> case - it got tainted by first warning, not by some module. The abrt's
> dedupe mechanism then merged three duplicate warnings to the latest one and
> then discarded everything (IIRC I reported this in a separate bug).

- yes, this is a known bug and I think it has already been fixed (at least in upstream)
Comment 4 Nikola Pajkovsky 2012-06-14 04:52:35 EDT
(In reply to comment #3)
> (In reply to comment #2)
> > I think that kernel should log waht tainted it.
> > 
> > BTW after I reported this bug, I learned why the kernel got tainted in my
> > case - it got tainted by first warning, not by some module. The abrt's
> > dedupe mechanism then merged three duplicate warnings to the latest one and
> > then discarded everything (IIRC I reported this in a separate bug).
> 
> - yes, this is a known bug and I think it has already been fixed (at least
> in upstream)

it's fixed by commit

commit 4586e9e40c493cef93e08a8dee2fc0768593da50
Author: Nikola Pajkovsky <npajkovs@redhat.com>
Date:   Fri May 4 14:48:55 2012 +0200

    oops: don't create oops dir in reverse
    
    when kernel starts printing oops, only very first one is not tainted.
    If we start in reverse, it will firstly create direcotry with tainted oops
    and others will be deleted as dup of first one (if there are same), thus
    we loose NOT tainted oops.
    
    Signed-off-by: Nikola Pajkovsky <npajkovs@redhat.com>

but not yet released
Comment 5 RHEL Product and Program Management 2012-07-10 02:45:46 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 6 RHEL Product and Program Management 2012-07-10 19:02:59 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 7 Denys Vlasenko 2012-08-03 10:09:02 EDT
Yes, it is fixed in rhel6 git branch too:

commit 8b0956286967e92bd68c04eb4e051225f00fce44
Author: Jiri Moskovcak <jmoskovc@redhat.com>
Date:   Thu Jul 12 11:24:39 2012 +0200

    oops: don't create oops dir in reverse rhbz#814594

    when kernel starts printing oops, only very first one is not tainted.
    If we start in reverse, it will firstly create direcotry with tainted oops
    and others will be deleted as dup of first one (if there are same), thus
    we loose NOT tainted oops.

    Signed-off-by: Nikola Pajkovsky <npajkovs@redhat.com>
Comment 13 Jiri Moskovcak 2013-01-24 09:31:51 EST
Cause
   When a multiple kernel oops happens in a short period of time ABRT only the first one is relevant, because the later oopses might be just consequences of the first problem. ABRT was wrongly sorting the processed oopses, so it saved the last oops instead of the first one.
Consequence
   The most important first oops never got into problem report.
Fix
   Fixed the processing order.
Result
   In case of processing more oops at the same time the first one is correctly saved
Comment 14 errata-xmlrpc 2013-02-21 02:53:11 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0290.html

Note You need to log in before you can comment on or make changes to this bug.