Bug 808735 - Insufficient permissions on MTP devices for non-root users
Insufficient permissions on MTP devices for non-root users
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libmtp (Show other bugs)
6.2
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Bastien Nocera
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-31 07:36 EDT by o.h.weiergraeber
Modified: 2017-12-06 05:21 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-06 05:21:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description o.h.weiergraeber 2012-03-31 07:36:24 EDT
Description of problem:

My MTP device (an mp3 player) cannot be used in MTP mode by MTP-aware applications, notably Rhythmbox. The player is correctly recognized by the system; even lsusb list it as an MTP device. However, mtp-detect
only works as root, whereas non-root users get an empty list. This probably explains why the player is not recognized by Rhythmbox: ordinary users don't have sufficient permissions to access the device.
Obviously, I don't want to run applications like Rhythmbox as root!

In case it matters, I am not using private groups for my users. Adding them to groups "audio" or "video" did not have any effect.


Version-Release number of selected component (if applicable):
libmtp-1.0.1-2.el6.x86_64


How reproducible:
always


Steps to Reproduce:
1. Connect an MTP device
2. Execute mtp-detect

  
Actual results:
Works as root only.


Expected results:
Every user should be allowed to access an MTP device.


Additional info:
Comment 2 RHEL Product and Program Management 2012-07-10 04:46:22 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 RHEL Product and Program Management 2012-07-10 19:49:18 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 4 RHEL Product and Program Management 2012-09-07 01:37:49 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 5 Jan Kurik 2017-12-06 05:21:18 EST
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/

Note You need to log in before you can comment on or make changes to this bug.