Bug 808743 - SATA AHCI hotpluggable port fails to recognize eSATA drive the 2nd time (patch)
SATA AHCI hotpluggable port fails to recognize eSATA drive the 2nd time (patch)
Status: CLOSED DUPLICATE of bug 806676
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-31 08:20 EDT by Patrick
Modified: 2012-04-02 09:33 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-02 09:33:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Lin Ming's patch from LKML (3.76 KB, patch)
2012-03-31 08:23 EDT, Patrick
no flags Details | Diff

  None (edit)
Description Patrick 2012-03-31 08:20:23 EDT
Description of problem:
SATA AHCI hotpluggable port fails to recognize/activate eSATA drive the 2nd and more times.

Version-Release number of selected component (if applicable):
Fedora 16 with kernel-3.3.0-4.fc16.x86_64

How reproducible:
Boot PC with F16, log in to Gnome3 desktop and start Nautilus, plug eSATA cable into external harddisk and PC, put power cable into external harddisk, switch on external harddisk, wait for it to appear in Nautilus, mount it, unount it, switch off external harddisk, wait 2 minutes, switch on external harddisk again: external harddisk is no longer recognized, zero ata/sd related messages in /var/log/messages.

Steps to Reproduce:
1. boot PC with F16, login, start Nautilus, switch on external harddisk, mount, unmount
2. switch off external harddisk, wait 2 minutes
3. switch on external harddisk - harddisk is no longer recognized
  
Actual results:
Resources on external harddisk are not available when the harddisk is switched on the 2nd or more times.

Expected results:
Resources are available no matter how many times you turn the external harddisk on/off.

Additional info:
LKML report: https://lkml.org/lkml/2012/3/4/152

Patch by Lin Ming: http://marc.info/?l=linux-kernel&m=132996405028746&w=2
Comment 1 Patrick 2012-03-31 08:23:29 EDT
Created attachment 574200 [details]
Lin Ming's patch from LKML

This is the patch that Intel's Lin Ming sent to LKML in response to https://lkml.org/lkml/2012/3/4/152
Original patch in LKML post: http://marc.info/?l=linux-kernel&m=132996405028746&w=2
Comment 2 starfall 2012-03-31 21:58:37 EDT
I can confirm that the same issue exists on my main Fedora 16 system with kernel-3.3.0-4.fc16.x86_64.
Comment 3 Josh Boyer 2012-04-02 09:33:14 EDT

*** This bug has been marked as a duplicate of bug 806676 ***

Note You need to log in before you can comment on or make changes to this bug.