Bug 808746 - [abrt] firewall-applet-0.2.4-1.fc17: firewall-applet:21:<module>:ImportError: No module named gi.repository
[abrt] firewall-applet-0.2.4-1.fc17: firewall-applet:21:<module>:ImportError:...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: firewalld (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
abrt_hash:ae41c918557b0e20bad971e0759...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-31 08:47 EDT by Tim Smith
Modified: 2012-04-24 00:26 EDT (History)
2 users (show)

See Also:
Fixed In Version: firewalld-0.2.5-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-24 00:26:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: smolt_data (4.94 KB, text/plain)
2012-03-31 08:47 EDT, Tim Smith
no flags Details

  None (edit)
Description Tim Smith 2012-03-31 08:47:21 EDT
libreport version: 2.0.10
abrt_version:   2.0.9
cmdline:        /usr/bin/python /usr/bin/firewall-applet
executable:     /usr/bin/firewall-applet
kernel:         3.3.0-8.fc17.x86_64
time:           Sat 31 Mar 2012 11:12:38 AM BST
uid:            500
username:       tim

smolt_data:     Text file, 5054 bytes

backtrace:
:firewall-applet:21:<module>:ImportError: No module named gi.repository
:
:Traceback (most recent call last):
:  File "/usr/bin/firewall-applet", line 21, in <module>
:    from gi.repository import Gtk, GLib, GObject, Gio, Notify, NMClient
:ImportError: No module named gi.repository
:
:Local variables in innermost frame:
:__builtins__: <module '__builtin__' (built-in)>
:__name__: '__main__'
:__file__: '/usr/bin/firewall-applet'
:__doc__: None
:__package__: None

comment:
:Installed from KDE LiveUSB, installed firewall-applet, ran firewall-applet from command line.
:Missing dependency?
Comment 1 Tim Smith 2012-03-31 08:47:26 EDT
Created attachment 574203 [details]
File: smolt_data
Comment 2 Jiri Popelka 2012-04-02 07:29:40 EDT
(In reply to comment #0)
> :Missing dependency?

Yes, firewall-applet should require pygobject3.
Comment 4 Fedora Update System 2012-04-20 15:54:42 EDT
firewalld-0.2.5-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/firewalld-0.2.5-1.fc17
Comment 5 Fedora Update System 2012-04-21 17:04:33 EDT
Package firewalld-0.2.5-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing firewalld-0.2.5-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-6323/firewalld-0.2.5-1.fc17
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-04-24 00:26:48 EDT
firewalld-0.2.5-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.